Microsoft Edge is now supported, yay!

Hello!
We are happy yo let you know that Microsoft Edge is not supported and that you can use the Web Editor on it :slight_smile:

It is still in its early days and we test as much as we could, but of course we need your invaluable feedback to make it work in the wild.

Please report here any bug you might encounter.
Thanks!

I'm trying to upload but it says please reselect the board from the dropdown, and so I did. After I did it SAME error. Please fix this I don't want to download it then extract and open it using the desktop app. Just in case you need to know I'm using a 3rd party Arduino and its not in the dropdown. It's called Maker Board from https://www.letsstartcoding.com/ and I'm using Edge on win 10. โ˜บโ˜บ

Hi @Derock, what is the name of the board you are using? Do you see it in the dropdown as 'Board at COMX'? If yes, clicking on the item in the dropdown should open a popup with the list of the compatible boards and you have to select one. What is that you 'don't want to download and extract'?

So the Maker Board has the same processor as the UNO (ATmega328P-AU SMD chip onboard), as this is not an official Arduino board it is not automatically detected and we cannot provide debugging or testing on it.

To use it you should connect it to your PC
Click on the dropdown as @smellai described
Select the Arduino/Genuino UNO from the board list
Make sure a COM port is selected
Press OK

You should now be able to use your board.

hello, I'm using this web editor. ive got trouble on the connection . I can't upload the codes on my module how can I fix this :(.

@Cosine_irene123 please give us more infos on your issue. Are you on Windows10 and Edge? Did you successfully install the daemon? What sketch are you trying to upload and on which board?

Uploading to Arduino is not working anymore:

arduino-builder/arduino-builder -compile -core-api-version 10611 -build-path /tmp/047197362 -hardware arduino-builder/hardware -hardware arduino-builder/packages/cores -tools arduino-builder/tools -tools arduino-builder/packages/tools -built-in-libraries arduino-builder/latest -libraries /tmp/847974111/pinned -libraries /tmp/847974111/custom -fqbn arduino:avr:mega -verbose=false /tmp/847974111/VR612_copy

avr-g++: error: missing device or architecture after '-mmcu=' exit status 1

@knarf10861, we have a problem with the Arduino Mega, we are fixing the problem and will release a new version as soon as possibile

@knarf10861, Arduino Mega now works again, please let us know if you still get that issue, thanks!

Hello,

I am using Microsoft Edge on Windows 10. I am able to type in code, verify, and upload, but when I attempt to select "Examples" from the far left part of the screen, it is unable to find anything in either Built In or From Libraries. Everything else continues to work even as it searches. At one point, not sure when, I was prompted to install drivers, but after I clicked OK, nothing appeared to have happened.

@ kolesh

Sometimes the built in libs and example sketches are quite slow to load. Not sure if this helps but I tend to work on my own stuff for a while and then check and see if its up on that side.

Not used edge too much as I prefer chrome for CREATE.

When you drivers installed I presume you mean during the bridge installation. If so have seen the same thing where it asks permission and then disappears. Yet it still picks up my boards just fine so I think its normal.

Using a surface and windows 10 I canโ€™t scroll in the coding window in edge.

Hi @falcon9202, I can reproduce your problem on Edge, I'll open an issue abou that, thanks for your report

every time I try to upload to my board it says expected '}' at end of input I put one there and it still says it

@ Borden

Most odd as my uploads that you cannot see from here work quite well.

Maybe you should START HERE.

Then at least you will know why my uploads work and yours do not.

MY PLUG IS NOT WORKING !!!!!!!!!!!!! I NEED IT URGENTLY AND IT IS NOT WORKING!!!!!!!!!!!! HELP ME PLEASE!!!!!

@ RaheematSofola2002

There is certainly no need to shout.

Please read this section then you can add all the information that your post is clearly missing.

Also ensure you completely followed this section and did not miss any steps.
Example the CERTIFICATE that it offers MUST be installed along with any drivers or firewall permissions.
If you bypassed any of those it will simply not work.

The download is giving me a zip file that is not supported. So I go to extract and it fails

@ericRB could you please share with us the unsupported download? We cannot reproduce your issue, thanks!