MIFAIR RC522 not reading RFID

Hey, I got the MFRC522 RFID Reader (http://www.banggood.com/MIFAIR-RC522-Chip-IC-Card-Induction-Module-RFID-Reader-p-81067.html) and I'm trying to get it working. I've tried a few sample code snippets with no luck. I've been using the example in this library - https://github.com/miguelbalboa/rfid/blob/master/examples/DumpInfo/DumpInfo.ino

The LED is lit as per the picture below: http://imgur.com/WU2xlaj

I had to solder the pins on, so maybe I messed something up when I soldered it? http://imgur.com/0h11SRM

I've double and triple checked the pins to make sure they're right, and I've tried other code examples. Anybody got any ideas on why it's not responding with anything? And is there something I can do to test if the chip is working or whether something has broke?


edit: I tried a different library which output this:

"Looking for MFRC522. Found chip MFRC522 Firmware ver. 0x92"

However when I present the cards there's still nothing - I even tried my oyster card and a contactless bank card and also nothing. When I check the status using this API is responds with 2 which means "General error".

Your soldering job is a bit... iffy. The solder is balled up on the pins and not flowed onto the PCB. You may well have not got very good connections on all pins there.

Try reflowing the joints with the iron tip nestled between the pin and the PCB pad (hopefully you have a fine tip) and add a TINY bit more solder to add flux and it should flow nicely and form a smooth filleted joint like you see on other PCBs.

A tip is to not overheat, or underheat. Mentally count up to about 3 - tip on, 1, 2, 3 - apply solder, watch it flow, iron off joint and let it cool without moving things and you should get a nice, shiny smooth joint.

Start there, then begin debugging your code.

Cheers Jacob

Hey, thanks for your help. I just tried reflowing the solder and the connections seem better but still no change when I plug everything back in. Something I found strange was even when 3.3v and Ground aren't attached the on board LED is still lit and the serial monitor still says - "Looking for MFRC522. Found chip MFRC522 Firmware ver. 0x92."

That could be parasitic power being supplied via your inputs and the protection diodes in the device itself.

Resolve this first as that is not a healthy way for it to work at all.

You may have a supply issue to the device. Check with just power and nothing else connected that the device is powered up.

Also - this is a 3.3v device, is your arduino a 3.3v setup?

I found this library/demo here for the same reader, maybe try it out