millis returns unsigned long as circle buffer library example but the type is no

millis returns unsigned long as in the circle buffer library example.
compiles on the uno but the due it doesnt like the type or just making the vareable that works with millis ?
please help.
Would this happen with the artimis apollo 3 or the feather m4?

https://www.arduino.cc/reference/en/language/functions/time/millis/

Please provide a complete, minimal sketch that demonstrates the problem.

Ok it is the first example in circle buffer library.
Runs on uno and compiles does not compile on due
Creating a unsigned long in due throws a error.

I'm trying to use the Mills() function.

Please post a link (using the chain links icon on the forum toolbar to make it clickable) to where you downloaded that “circle buffer” library from. Or if you installed it using Library Manger (Sketch > Include Library > Manage Libraries in the Arduino IDE or Libraries > Library Manager in the Arduino Web Editor) then say so and state the full name of the library.

Please do this:

  • When you encounter an error, you’ll see a button on the right side of the orange bar “Copy error messages” in the Arduino IDE (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button…
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the error between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

If the text exceeds the forum’s 9000 character limit, save it to a .txt file and post it as an attachment. If you click the “Reply” button here, you will see an “Attachments and other settings” link.