mini w/ usb: avrdude error

hi-
(absolute newbie here)
I can compile the installed “blink” script on the desktop just fine, and when I upload, the board tx/rx lights blink 4 x’s, but then the error message response is:

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I don’t have any idea how to read this error. Is it my board work?

I’m using mac os 10.4.9, have assembled the mini with the usb adaptor according to arduino specs (or so I believe,) loaded the usb driver (intel) and arduino (intel.) When I plug in, my board gives two quick blinks on the tx/rx leds on the board. I’ve checked the wiring numerous times.

I have an LED that’s 1.8v (couldn’t find info on best kind to use in this instance) and have tried it on 13. I switched it to 9 (altered the script as well,) and used a 10k resistor as buffer. Neither way makes a change in the upload error response.

If there are any suggestions, particularly if they can point me in the direction of help docs (I’ve scoured the arduino site) I would really appreciate it.

  • snax

Can you post a picture of the wiring? I know you said you checked it, but sometimes it’s good to get another pair of eyes.

If you leave the LED on pin 13, what does it do when you reset the board (or unplug and reconnect the USB cable)?

You might check the troubleshooting guide: http://www.arduino.cc/en/Guide/Troubleshooting, though I’m not sure any of it applies.

hi mellis-

i posted an image here: http://www.loreleipepi.com/snax-boardshot.jpg

I put the LED back to pin 13, tried again. The LED does not do anything. (new LED, tested w/ 9v battery.) I went through the troubleshooting docs backwards and forwards. Maybe seeing the picture will help...

  • snax

Hmm... the wiring looks okay to me too. Maybe someone else will spot something though.

It sounds like either your Mini's not getting powered or it doesn't have the bootloader on it. Can you test it with a meter to check that it has power? And that it's ground properly?

ummmm... was I supposed to burn the bootloader onto the board to start?

No, it should come with a bootloader, but it may have gotten overwritten or corrupted somehow.

okay, so I"m back. I've run the multimeter around the system, and it's feeding correctly, grounded correctly. I've checked the most recent posts, including the Mac .kext issue. My Mac is seeing the board, according to my profiler. The software compiles the program and reads "uploading to i/o board" but then the error response is posted in the software feedback window.

is it possible that it's time to exchange the board (Make online store)? I'm not advanced enough yet to do all of the workaround for burning a new version of the bootloader.

help is appreciated. thanks for your time.

-snax

You might try it on Windows machine or another Mac, just to make sure it's not something weird with the computer. But if it still doesn't work, yeah, it might be time to exchange it.

okay. thanks.

last update. problem solved. I found an inconsistent meter reading on the breadboard circuitry, but it didn't make sense. I ripped the back off my breadboard, an lo and behold, the connection was interrupted by poor channel connection. Radio Shack, go figure. A whole strip of metal was MISSING. I replaced the board, and everything works.

Hi,

have a similar problem:
connected brand new mini with brand new mini usb as described, connect usb cable to pc --> led starts after a view seconds to blink (very fast)
try to load "blink" too (under windows xp environment, arduino 0009), get same error:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

go to command line, trying avrdude with command:

avrdude -c avrisp2 -p m168 -P com4 -v

get the error

avrdude: stk500_2_ReceiveMessage(): timeout

Tried it with WinAVR and AVRStudio - no success :cry: Every time I try, only the TX LED ond the USB is flashing :-?

I also tried your solution using a different breadboard, no success too.

Greg

Pizzamann: are you resetting the board just before clicking the Upload button? You need to upload the sketch during the first few seconds after a reset (i.e. when the LED is off).

I did, more then once ... :frowning:

finaly it worked ...

start upload ... wait ... reset arduino ... DONE :slight_smile:

::slight_smile:

heloo!! i had same problem and i resolved :D. I saw the com port, and chose other port, and the problem was resolved. :), Good luck!!

I am new to this, and worse yet, I am a mechanical engineer.

I had the same problem while using a Gator board.

I finally got the blink sketch to work to use.

Within Arduino 0018-gator, I pressed CTR-R to verify/compile. Then, on the gator board, I pressed reset buttom once. Then I pressed CTR-U and waited for the dialog box "press the reset button" to come on. I then pressed the reset button and pressed the OK button on the dialog box while the red LED was still blinking (about 1/2 second after pressing reset).

This took a lot of trials and errors and seems a rather random method. If everyone has a more elegant method, please let me know.

J

I am new to this, and worse yet, I am a mechanical engineer.

Hey, now, there's nothing wrong with being a mechanical engineer. I'm one, too.

Hey, now, there's nothing wrong with being a mechanical engineer. I'm one, too.

Thanks dude!

I have pretty much the same problem, and "solution" when using Sparkfun's FTDI 5V and an Arduino Pro. Bump for a more elegant solution. (I'm quickly tiring of timing my reset buttonmashing, though finally there IS a use for my Nintendo skills) :wink: