Minor bug in pins_arduino.c?

From pins_arduino.c ...

const uint16_t PROGMEM port_to_input_PGM[] = {
      [glow]NOT_A_PIN,  // <-- Shouldn't this be NOT_A_PORT ?[/glow]
      &PINA,
      &PINB,
      &PINC,
      &PIND,
      &PINE,
      &PINF,
      &PING,
      &PINH,
      [glow]NOT_A_PIN,  // <-- Shouldn't this be NOT_A_PORT ?[/glow]
      &PINJ,
      &PINK,
      &PINL,
};

NOT_A_PORT and NOT_A_PIN are both defined to be "0" so functionally it won't make any difference.

Here I think PIN means Port INput register, so its correct, if confusing.

Ah, yes.

In that case, there are inconsistencies in various other definitions. But, given the lack of interest and the fact that the "bug" doesn't cause any problems, I'm going to let it go.

don't you know to ignore the man behind the curtain?

:wink:

I wish I could ignore him.

I've working with René Bohne's1 ATtiny2313 core and R. Wiersma's1 ATtiny84 core. So I need to know what "NOT_A_PIN" is (along with a few other oddities).

1 THANK YOU!
And thank you bill2009 for publishing your work ATtiny change.