Mint Linux 14 IDE 1.0.(2-4) issues "usb lillypad" failed upload

Before details my question is, Is there are a way to install or configure the IDE in mint linux 14 so that it will properly upload to a "usb lillypad" and get rid of the menu bugs?

Bugs that I am noticing- Bug0 After using the IDE for a period of time the menus will start to offset. i.e. a menu is selected and the drop-down occurs in on the wrong area of the screen. Bug1 any selected menu item will be whited out. Most importantly, Bug2 - the ide seems to reset the usb lillypad partway through an upload causing all uploads to fail.

more on Bug2- I did try with another disto and the ide worked fine. I don't really want to explore other distros just for the sake of the ide, so that is why I'm am interested in other ways to configure. Is it possible the version of java on mint doesn't play well with the ide? Also- Arduino micro and uno take uploads fine, its just the lillypad that is having the issue

I just tried using the openjdk-6-jre instead of the 7 one and the ide wouldn't even fire up.

any other ideas?