Mise en place domitique

Bonjour,

Comme promis, voici le détail de mon projet.

Je veux donc mettre en place un peu de domotique dans ma maison pour faciliter la vie de ma famille et moi-même.

Le but est de commander :
l’éclairage intérieur via capteurs de présence et luminosité (plus tempo lorsque plus de mouvement)
via commande par IPhone (pour commencer par bouton, puis en programmant l’IPhone en utilisant la position GPS) l’éclairage extérieur, car comme on est isolé, la nuit c’est noir dehors (surtout quand on part ou arrive en voiture)
le transfert de chaleur entre le salon et la chambre, car le salon est chauffé par un poile, et la nuit je pense récupérer la chaleur du salon, il faut bien sûr des sondes de température dans les deux pièces pour sécuriser les températures
le chauffage électrique de la chambre (s’il n’y a pas assez de chaleur au salon pour maintenir la température demandée dans la chambre)
le chauffage de la salle de bain

Pour cela j’utilise :
un Arduino Mega
EthernetShied
un platine relais 16 cannaux
pour les alim 12 et 5 volt, j’ai récupéré l’alim d’un vieux boitier externe (qui avait à l’origine un graveur)

Dans un premier temps j’ai fait le montage sans le relier à la puissance, comme il y a une LED par relais, ça permet de vérifier le bon fonctionnement du système avant de jouer avec du 220V (oui, oui, je ne veux pas inir comme José moi).

Pour commencer, je ne connecte pas EthernetShied, je simule les boutons de commande de l’IPhone par des entrées physiques sur l’Arduino.

Hier soir, premier test, la platine relais répond bien en manuel, par contre pas moyen de transférer le programme du PC vers l’Arduino, snif ……

image.jpg

Bienvenue et bon succès mais ......il existe un sujet à lire :

Extrait des "Réglement et charte du forum A lire impérativement avant de poster" http://arduino.cc/forum/index.php/topic,102175.0.html

N'utilisez pas des images trop grandes en dimensions et en taille, car tout le monde ne possède pas une connexion ADSL et une résolution d'écran élevée. Les images postées ne doivent pas dépasser 800 par 600 pixels ! Si l’image est plus grande, mettez une miniature (redirigeant vers l’image plus grande).]

C'est tout bête mais pour être en mesure de te répondre il faut enregistrer l'image et la lire avec un logiciel spécialisé, les volontaires sont soudainement moins nombreux. A lors que si tu respecte le 800x600 la lecture se fait directement.

Pour réduire les images : entre autres logiciels : Gimp : opensource, multiplateforme, gratuit.

Désolé, je suis au boulot et je n'ai que mon iphone ... Je ne le referai plus.

Je le ferai ce soir, par contre c'est juste le plan de l'instal.

En fait je suis en Time out ....

Mes réglages sont : Type de carte : Arduino Mega 2500 ou Mega ADK Port série : COM1 Programmateur : Parallel Programmer

Bonjour,

Malicati: En fait je suis en Time out ....

"stk500 timeout" ? Si oui ça peut vouloir dire que, soit : - le port série choisi n'est pas le bon - la carte est bloqué à cause d'un programme précédent utilisant D0/D1 - le montage empêche la carte de fonctionner

68tjs merci pour ces rappels.

Malicati, il faut rééditer le premier message afin de une nouvelle image avec les bonnes dimensions.
J’ai supprimé le fichier incriminé.

Oh vénéré modo il faut rééditer ton message pour ajouter les mots qui manquent :grin: :grin: :grin: :grin:

Bonjour,

Je viens de m’y remettre, ce week end, ça a été repos.

En fait, je me demande si mon problème de transfert ne vient pas d’un problème de l’instal de l’IDE (voir copie d’écran).

Je suis au boulot, je pense que ce soir en arrivant, au lieu de le faire sur le PC je vais me mettre sur mon MAC, et on va voir ce qui se passe ……

Bonjour,

Malicati: En fait, je me demande si mon problème de transfert ne vient pas d’un problème de l’instal de l’IDE (voir copie d’écran).

Dans la capture d'écran je ne vois que des "warning", ce ne sont pas des erreurs ...

À mon avis c'est un problème de montage qui bloque ta carte. Utilises tu D0 ou D1 dans ton montage / câblage ?

J’ai tout déconnecté, c’est pareil.

Par contre je suis sous XP et j’ai pas installé de driver, et d’après ce que j’ai lu, ça peut venir de la .,

Je vais essayer sur le Mac je pense.

Malicati: Par contre je suis sous XP et j'ai pas installé de driver, et d'après ce que j'ai lu, ça peut venir de la .,,,

Copie/colle le texte complet de l'erreur.

Bonjour,

Après avoir pas mal été occupé, j’ai fait des tests. J’ai déconnecté complètement l’Ardiono => pareil J’ai fait un avoid setup et un avoid loop vide => pareil quand je compile, j’ai les erreurs suivantes :

c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp: In function 'void store_char(unsigned char, ring_buffer*)':
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp:83: warning: comparison between signed and unsigned integer expressions
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp: In function 'void __vector_25()':
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp:117: warning: unused variable 'c'
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp: In function 'void __vector_36()':
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp:143: warning: unused variable 'c'
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp: In function 'void __vector_51()':
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp:160: warning: unused variable 'c'
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp: In function 'void __vector_54()':
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp:177: warning: unused variable 'c'
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp: In member function 'void HardwareSerial::begin(long unsigned int, byte)':
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp:364: warning: unused variable 'current_config'
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp: In member function 'virtual size_t HardwareSerial::write(uint8_t)':
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\HardwareSerial.cpp:463: warning: comparison between signed and unsigned integer expressions
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\Print.cpp: In member function 'size_t Print::print(const __FlashStringHelper*)':
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\Print.cpp:44: warning: '__progmem__' attribute ignored
c:\Users\to39182\My Documents\arduino-1.0.2-windows\arduino-1.0.2\hardware\arduino\cores\arduino\Tone.cpp:94: warning: only initialized variables can be placed into program memory area

Je n’ai pas encore reconnecté mon Mac (on a modifié l’implantation du salon, et j’ai eu la flemme de tout reconnecter) …… il me reste ce test

Mais je ne m’avoue pas vaincu, j’ai toujours gagné la bataille face à un PC ……. (Petit Co….)

Je vous donnerai des nouvelles, ou si une personne à une idée …..

bonjour, ca ressemble à une incompatibilité de version de l'ide avec ton code ou librairies.

Ce ne sont que des warning, warning != error ! Normalement tu doit pouvoir uploader ton programme sans problème même avec ces warnings. Au passage la version 1.0.3 de l'ide est sorti depuis un moment déjà ;)

Bonjour,

Hier soir j’ai installé l’IDE sur mon MAC, et là, aucun pb …… c’est donc bien l’IDE sur le PC qui a un pb ……

Je vais charger la dernière version de l’IDE et l’installer sur une clef, oui, ma femme risque de me taper si je monopolise la TV …. Remarquez c’est mieux de travailler sur un 42’’ que sur un 17’’ ………

Sinon, hier soir une idée m’ai venu, si si des fois ça m’arrive, je pense que je vais rajouter un bonton dans l’interface des IPhones un bouton d’alerte qui envoie courriel et/ou SMS sur plusieurs téléphones, je pense que ça peut être pas mal J

Pour les Iphones, j’ai vu l’appli My Cmd, qui en fait utilise le http CGI, ça n’a pas l’air très compliqué à utiliser, et comme, je pense m’attaquer à iOS après, ça sera plus simple pour la transposition.

Y-a-t-il une personne qui l’a utiliser ?

Bonjour, J’aimerai faire fonctionner le téversement d’un ordinateur portable vers un Arduino Mega.

J’ai essayé sur tous les ports USB, c’est à chaque fois la même erreur : time out ……

Par contre je me dis qu’il doit y avoir un pilote ou un paramétrage à faire ….. mais là je bute …..

Voici le message lors du téléversement :

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "c:\Users\to39182\My Documents\Arduino\Arduino\IDE\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM1 Using Programmer : wiring Overriding Baud Rate : 115200 avrdude: wiring_open(): releasing DTR/RTS avrdude: wiring_open(): asserting DTR/RTS avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: Send: . [1b] . [01] . [00] . [01] . [0e] . [01] . [14] avrdude: Recv: avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_getsync(): timeout communicating with programmer

avrdude done. Thank you.

Bonjour,

Quel carte arduino ? Quel version de l'ide ?

-> Il faut bien choisir la bonne carte et le bon port série dans la liste du menu "tools". -> la dernière version de l'ide est la 1.0.3