Missing ctype.h file

Trying to compile the IRremote library ReceiveDemo example on a Dell laptop running Windows 8.1 and I get the following error. Compiles fine on my Windows 10 desktop with IDE 1.8.15.

I tried re-installing the latest version of the IDE (1.8.16). Don't know what else to try.

Arduino: 1.8.16 (Windows 8.1), Board: "Arduino Uno"

In file included from C:\Users\dad\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.4\cores\arduino/Arduino.h:231:0,

 from C:\Users\dad\Documents\Arduino\libraries\IRremote\examples\ReceiveDemo\ReceiveDemo.ino:34:

C:\Users\dad\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.4\cores\arduino/WCharacter.h:23:10: fatal error: ctype.h: No such file or directory

 #include <ctype.h>

          ^~~~~~~~~

compilation terminated.

exit status 1

Error compiling for board Arduino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Is ctype.h anywhere on the computer?

It was present in the ESP32 and ESP8266 core files, but not in the AVR core files. So I copied it to the, I think, right place in the AVR core. Then I tried to compile the example again and got a different file missing error. Another C++ library.

I deleted the Arduino15 folder and the Arduino IDE folders and re-installed the IDE version 1.8.16. Now the IRremote library examples compile.

Must have been a bad IDE install from the beginning.

2 Likes