Misuratore di corrente AC con ATtiny84. (ora SO quanto mi costi!)

sono andato in una altra stanza al lato opposto della casa

Dalubar hai provato con una lampada da 100W ???????? a me non segna forse il range e' troppo basso ....

ancora non mollo

tostapane 220v 500w

inserito fluke75 in serie allo strumento e al carico in portata Ampere 10A

fluke 2.03A I = 1.6A P = 300W Vo = 2.57V V = 220V

Tra le altre cose mi era venuto in mente magari di inserire un fattore di correzione impostato dal pulsantino e visualizzato sul display per compensare le differenze costruttive dei vari sensori ....... sembra che questi sensori non sono tutti uguali ... e hanno pure la garanzia per 5 anni se non erro

il parametro c'e' basta tirarlo fuori e impostarlo 0.75F

Giangi, c'è una cosa che non capisco di questa misura col Fluke: tu specifichi (e fai benissimo) che è posto in serie allo strumento. Cioè il primo valore è quello rilevato dal Fluke (2.03A) e tutti gli altri sono quelli dello strumento? Cambia qualcosa se fai la misura in modo separato, prima con lo strumento e poi col Fluke (o viceversa, naturalmente)

gia' fatto non cambia nulla sono 2 amperometri in serie ........

giangi2:
gia’ fatto non cambia nulla sono 2 amperometri in serie …

Sì, lo so benissimo, non è certo per farti spazientire, ma solo per cercare di trovare una causa, magari stupida, che giustifichi il tuo problema; se tutto fose perfetto dovrfebbe andare bene, no? ovvio che c’è qualcosa che non va, si cerca di suggerirti una qualche stravagante idea, ma forse è meglio di no :~

Uhmm, direi che non ci siamo...sei ancora lontano dai valori che dovrebbe fornire il misuratore.

comunque ho portato il misuratore su una presa da 16A ... misurata la tensione 225V sotto carica 223 circa la cosa e' migliorata infatti ora segna 1200 1300w ma ancora stiamo lontani dalla precisione di quello di dalubar ..... ... il problema secondo me non bisogna acquisire solo la CORRENTE ma e' legato il tutto anche alla TENSIONE ....

Che la TENSIONE sia importante è certo, ma una differenza di pochi volts (223 su 230) non giustifica però il valore da te rilevato (1300 su 2000W) che è più del 35% in meno del valore dovuto. Il misuratore è fatto per un uso "casalingo", da collegare a una utenza domestica a 230V e non l'ho mai definito "di precisione", ma devo dire che in condizioni normali la differenza tra il valore reale e quello misurato è davvero poca... una differenza di 50 o 100W su oltre 2000W fanno una precisione migliore del 5%, per me più che accettabile.

Ad esempio, su un tostapane da 500W l'errore è dello 0% (ho anche il video ma stavolta ve lo risparmio :)). E posso assicurare che questa volta la misura rimane praticamente stabile su quel valore.

Domani al LIDL SUPERMERCATI vendono un attrezzo del genere con display a lcd con misure varie V - I - W e consumi mensili e giornalieri con settaggio delle fascie orarie ... alla modica spesa di ????????????? 11 € .... me sa che me lo compro e recupero i pezzi ...... ho speso diverso tempo ma mi ha fatto imparare molte cose .... NON TE LA PRENDERE DALUBAR ....

E di che? Non devi assolutamente pensare che me la possa prendere in alcun modo, di certo con un semplice acquisto risolvi definitivamente il problema. Io sono uno di quelli "vecchia scuola" che prendono ancora una certa soddisfazione da questi progetti totalmente DIY, soprattutto quando li vedono funzionare, anche a costo di notti insonni (fortunatamente in questo caso non è stato così :sweat_smile:). Dispiace a me, invece, che tu sia incappato in tutte queste problematiche, ma magari chissà, se insisti un altro po' magari riesci a trovare l'arcano. :D

anche io modestamente infatti non mollo eh eh comunque ho cambiato la costante 0.75F nel valore originale 0.625 e le cose sono molto migliorate ..... ancora un piccolo ritocco e siamo a posto questo giustifica che i sensori non sono tutti uguali

ecco i valori

costante 0.75F

I = 1.6A P = 300W Vo = 2.57V V = 220V

costante 0.625

I = 2.00 A P = .350 W Vo = 2.57 V = 220

almeno ora la corrente che segna e' uguale a quella del fluke..

Dimenticavo una cosa importante .... Se vi interessano i trasformatori 220/9 da 2.3VA li ho trovati alla ESCO di TODI (PG) a 2,3 € pin to pin compatibili

La cosa strana e' che le misure non sono ripetibili ...........con un phone da 1200 w al primo scatto sale a 800w al secondo aumenta il ventilatore di velocita' e scalda di piu' ma lo strumento rimane a 800W

Eccomi di nuovo con l'ODISSEA del MISURATORE

Stamane come vi avevo accennato ho acquistato il misuratore all' LIDL e devo dire che funziona bene e le letture sono veritiere .-... da una analisi (come si era pensato) il problema sta nella lettura della corrente quindi il sensore 1.6A il sensore e 2.1 il misuratore dell' LIDL (quindi programma e c...i vari non c'entrano ) ho paura che le caratteristiche del sensore da me acquistato non vanno bene con i parametri impostati .......... MA E' UN LEM LTSR 25-NP

MA SOLO IO HO FATTO IL MISURATORE ????? POSSIBILE CHE NON CI SIA QUALCHE ALTRA ANIMA per un confronto ???????

AL limite spedisco il tutto a DALUBAR (senza trafo e display ... pesa di meno) e ci gioca lui

Aspetto info

giangi2: Eccomi di nuovo con l'ODISSEA del MISURATORE

Stamane come vi avevo accennato ho acquistato il misuratore all' LIDL e devo dire che funziona bene e le letture sono veritiere .-... da una analisi (come si era pensato) il problema sta nella lettura della corrente quindi il sensore 1.6A il sensore e 2.1 il misuratore dell' LIDL (quindi programma e c...i vari non c'entrano ) ho paura che le caratteristiche del sensore da me acquistato non vanno bene con i parametri impostati ..........

MA SOLO IO HO FATTO IL MISURATORE ????? POSSIBILE CHE NON CI SIA QUALCHE ALTRA ANIMA per un confronto ???????

AL limite spedisco il tutto a DALUBAR (senza trafo e display ... pesa di meno) e ci gioca lui

Aspetto info

Ciao, anch'io ho creato una parte del misuratore. Ovvero non ho il display e l'alimentazione la prendo da Arduino. Nei post precedenti avevo segnalato che con il mio sensore LEM CASR-50 non avevo letture, che avevo provato a portare il riferimento a 1.65 con un partitore di due resistenze da 10K alimentato dal 3.3 V di Arduino ma neanche coasì riuscivo ad avere letture di piccole potenze, provando con un carico da 2000W me ne leggeva pochi ma non ho otttenuto risposte quindi ho penato che fosse solo un problema mio... visto che il mio intento è leggermente diverso, ovvero non voglio ottenere un misuratore vero e proprio ma mi serve solo sapere su un utilizzatore è attivo, sto provando a percorrere la via di un altro sensore. prima di spendere altri soldi però sto provando a documentarmi bene perchè anche nell'altro topic aperto per l'uso di tale sensore non mi ha dipanatro i dubbi, quindi ho postato nell'asezione internazionale e con una risposta che ho avuto ho cominciato a capire qualcosa di più e forse riesco ad arrivare in fondo. Il mio problema è che a livello hardware devo ancora percorrere molta strada percui ogni ostacolo mi porta via un sacco di tempo, mente con il software vado via liscio di solito... Concludendo anch'io ho acquistato il sensore da RS am vista la mia poca esperienza nel campo ben mi guarda da scrivergli che il loro sensore è difettoso, quasi sicuramnete sono io che sbaglio qualcosa...

Ciao EDIT: Rilegendo mi sono reso conto che quanto scritto potrebbe essere interpretato come polemico, l'intento è tutt'altro anzi chi mi ha risposto è stato sempre cortese e ha sicuramente risposto con precisione quello che volevo trasmettere è che molto spesso gli aiuti non sono risolutivi perché per chi come me ha poca esperienza e non riesce a capirli appieno deve rimboccarsi le maniche e fare esperienza. Poi per mia propensione, scarsità di tempo e di fondi se un problema mi risulta insormontabile cerco di percorrere un'altra strada che mi porti al mio obiettivo e poi magari torno sui miei passi per tentare di risolvere il problema. Ciao di nuovo!

Ciao Questi sensori dovrebbero essere molto affidabili ... infatti se ci fai passare una corrente continua sono perfetti ... il problema nasce quando ci fai passare l'AC tra regimi rms e sinusoidali sono un bel casino anche perche' la tensione che nasce (con uno zero di 2.5V cc) si somma una variabile alternata che deve essere campionata ...... (qui potrebbero nascere problemi di precisione).. la cosa strana e che sia il prototipo ti DALUBAR che il mio sono identici (all'apparenza) stesso sensore , stesso sketch , stesso ATTINY anzi una cosa cambia il mio e' ATTINY84A ma non cambia nulla (almeno spero), mi sono fatto mandare un secondo sensore dalla RS (a gratis) dichirandolo guasto .. ma la lettura della corrente risulta inferiore a quella reale e di conseguenza i watt letti ..... Non so piu' cosa fare ......... e la prima volta che mi succede una cosa simile


Saluti

Ciao giangi, dopo le 20.00 contattami su Skype e vediamo una buona volta di risolvere.

L'Attiny84A è la naturale evoluzione dell'Attiny84, integra un nuovo core che permette di lavorare con tensioni minime di 1,8V come il modello Attiny84V ma tollera i 20 MHz come il modello normale.

Leggendo queste 16 pagine dopo un anno che non si commenta più non posso fare altro che pensare alle miliaia di ore perse da altrettanti utenti per leggere 16 pagine di autentico entusiasmo si trasformano improvvisamente nel NULLA :astonished:

Andando al bagno mentre ero sulla tazza ragionavo sul misuratore…(accade anche a voi una cosa del gerùnere vero?)

Penso che il problema delle differenza sulle misure sia questa:

La tensione di offset di 2.5volts del sensore lem varia da sensore a sensore quindi non è una REFV, inoltre e suscettibile anche al 7805 di alimentazione. Quindi và misurata all’accensione dello strumento per fare una calibrazione, ma come fare una calibrazione se lo strumento è SEMPRE collegato al carico? O si stacca il carico e si fà la calibrazione (la calibrazione consiste solo nel leggere il valore con ADC e memorizzare l’offset) oppure si mette uno rilevatore di zero crossing sulla corrente in modo che quando arriva lo zero crossing si fà la lettura dell’offset entro pochi microsecondi: FINITA la calibrazione.
Con questa modifica si migliora MA NON del tutto, bisogna anche leggere la tensione sinosuidale , mettere uno zero crossing sulla tensione sinusoidale( hardware o software) e calcolare il cosFI, attualmente un cosFI impostato per statistica non è accettabile.
Per levare quell’odiosa calibrazione del LEM e quindi evitare di mettere i 2 zero-crossing hardware (e farli solo software mediante almeno 2000 letture continue dell’adc al secondo) bisogna mettere nel menù dello strumento una funzione CALIBRAZIONE per calibrare lo strumento da fare in assenza di carico e memorizzare il valore in eerom.

Considero lo strumento proposto dall’autore dalubar un ottimo strumento da modificare come ho detto per renderlo operativo ed efficiente
ciao ciao

La fortuna dei progetti open source è che ognuno può guardarli, studiarli e modificarli. Visto che dalubar ha lasciato qui schemi e codice, potresti lavorarci sopra e fornire il progetto con le modifiche da te segnalate, che mi sembrano molto interessanti ;)

il progetto prevede gia' una calibrazione automatica dell'offset, e comunque i 2,5v non sono un qualcosa che viene dichiarato dal costruttore, semplicemente sono il centro della sinusoide nel caso si misuri un segnale sinusoidale. Logicamente se l'alimentazione e' ballerina, ne risente anche la precisione, ma un 7805 come stabilizzatore basta e avanza per questa situazione secondo me. Gli altri due parametri, tensione di rete e fattore di potenza, sono volutamente stati scelti fissi per semplicita'. E' normale che se abiti in un posto dove normalmente la 230v risulta essere 190v non ti ritroverai con la potenza reale che vai a pagare all'enel. Cosi' come anche se a casa tua usi regolarmente ed in maggior parte carichi induttivi o capacitivi il fattore di potenza puo' alterare la misura. In questi casi pero' puoi sempre alterare i due parametri fissi, diciamo che e' normale che si adatteranno i due parametri alla propria situazione. Aggiungere tensione e sfasamento reali, misurati, significa fare un nuovo progetto, cambiando anche tipo di micro.

Quindi si dovrebbe affrontare il discorso sotto vari punti di vista, se ad esempio si ci lamenta di problemi con la misura di corrente e' un discorso, se si ci lamenta del valore di potenza reale ricavato e' tutt' un altro discorso.