MKR 1310 Failed to start the module

I bought new MKR 1310 from arduino store I was going to use it for the first time. I was able to upload blink sketch and it was working.

When I upload the code from example FirstConfiguration all i receive on serial is below

20:37:56.335 -> Welcome to MKRWAN1300/1310 first configuration sketch
20:37:56.335 -> Register to your favourite LoRa network and we are ready to go!
20:37:58.744 -> Failed to start module

I had the same problem. Another person here next tried the other MKRWAN library and that fixed it for him and for me. To be clear, FirstConfiguration from MKRWAN_V2 fails but the same "sketch" from MKRWAN works. The difference is #include <MKRWAN.h> vs #include <MKRWAN_v2.h>. Finding the difference inside there "is left as an exercize for the reader". (TM)

This was tested on MKR 1310 received new 17Nov21.

Hi all, i have the same problem but if I use the MKRWAN.h library the only difference is that when the if (!modem.begin(EU868)) function is called, the device wait unlimited...

Maybe the device is damaged/faulty ?
what do you advise me to do?

I do not have another device here to test... :upside_down_face:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.