MKR SD Card not working? Uno is fine

I have now tried two MKR SD shields on two MKR1000 boards and none of them will initialize the SD card that works fine on an Uno+Ethernet. Using the CardInfo sample with various versions of the SD library fail to work on the MKR SD shield. Uno works fine. The card is 8Gb SanDisk SDHC with FAT32.

I tried using the SDFat library directly and added diagnostic prints and it seems like some of the commands (CMD0, CMD8) work, but even CMD41 (to determine SDHC) returns different results on the MKR1000/SD (bad) vs. the Uno+Ethernet shield (good). The readCID fails - it just keeps getting 0xFF data back from the card.

I am using IDE 1.8.1.

Has anyone been able to get an MKR1000+SD workinging using the current library and IDE?

Thanks,

Guy

Hi there, I just came across the same issue. It works nicely with an other microSD break out board, but not with the MKR SD Proto Shield (TSX00004). I've checked all the pin connections between the MKR1000 board and the card slot of the MKR SD Proto Shield and it seems, that the GND pins are not connected. :o wolf7

I was right. :sunglasses:

I've connected the 3rd contact from the left, when you look in the insertion direction, to the ground, which is at the card slot housing for example. Now it works. See the picture: |500x409

wolf7

Good job :slight_smile:

Thanks a lot wolf7 !!

It's 7/24/2019 and they are still selling these faulty boards without the GND connected! We ordered 2 directly from the Arduino website.

This seems to have been corrected at the source. I ordered one of these SD shields for my MKR1010 on 13 Jan 2020 directly from Arduino, and the SD Cardinfo example sketch works directly out of the box. This was a replacement for the same SD shield but ordered from Rapid (UK) Electronics on 07 Jan 2020 which required soldering SD pin 3 to ground.