MKR Wifi 1010 doesn't connect!

I have the Opla kit. I am trying to set up my first Thing but after adding the variables and connecting the MKR Wifi 1010, I can't seem to connect to my wifi router. I enter the SSID and password for my 2.4Ghz network, but it only tries to connect to my 5Ghz network??
I've tried deleting the Thing and starting over. I've tried using another MKR Wifi 1010 and I even tried a different computer, but I keep getting the same result.
I even tried setting up a hotspot on my iPhone but I get the same result.

Thanks
Richard

This is very unlikely as the MKR Wifi 1010's radio uses u-blox NINA-W102 which only supports 2.4-2.5 Ghz range for Wi-Fi

In the Serial monitor, it only shows the SSID for my 5Ghz network?

post your code

Hello, do yourself a favour and please read How to get the best out of this forum and modify your post accordingly (including code tags).

My bad! Sorry. But, It's not my code. In the Serial Monitor, it says the latest firmware version is 1.4.7 but in the WifiNina Updater, the firmware only goes up to 1.4.5. So, when I try to upload a sketch in the IoT cloud it says I have to update my device. But I get a Something Went Wrong error! Because I can't update to the latest firmware, I can't connect to my Wifi router. The router doesn't even show it's connecting after I enter the SSID and password.

which code is it then?

The code is from the Opla Kit Alarm.