MKR1000 connection problem

Hey all,

I have problems connecting a new Genuino MKR1000 to my Laptop.
The Laptop uses Ubuntu 16.04 and had no problems working with a Genuino Uno.
But the MKR is not recognized probably.
In dmesg I found the following:

[  681.528007] usb 1-2: new full-speed USB device number 26 using xhci_hcd
[  682.239468] usb 1-2: New USB device found, idVendor=2341, idProduct=824e
[  682.239492] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  682.239500] usb 1-2: Product: Genuino MKR1000
[  682.239507] usb 1-2: Manufacturer: Arduino LLC
[  682.242717] usb 1-2: can't set config #1, error -71
[  682.242879] usb 1-2: USB disconnect, device number 26
...
[  690.763281] usb 1-2: device descriptor read/64, error -110
[  697.650722] usb 1-2: device descriptor read/64, error -71
...
[  712.225369] usb 1-2: Device not responding to setup address.
[  712.429685] usb 1-2: Device not responding to setup address.
[  712.632978] usb 1-2: device not accepting address 32, error -71

My phone is working normally with the same port and cable.

Has anyone an idea?
Thanks in advance :slight_smile:

Any LINUX users want to chime in here ?

All I have is this below and its the same answer I just posted for a mac user.

Have you tried the "quickly double tap" the reset button.
This puts the MKR in bootloader mode and on another com port

Also be aware that a lot of issues surround USB 3.0 ports so if that's all you have then it is preferable to use a powered USB 2.0 hub between the USB 3.0 port and the Arduino.

Take your time and read some of the other posts in this section as there are a lot of useful tips in getting your MKR up and running.

I presume you have been here and followed the advice shown.
There are a few more links on that page too worth looking at.

hello Lukas,

when you type "lsusb" on the command line, you should see the mkr1000 listed as "Arduino SA" device

$lsusb

Bus 002 Device 003: ID 0bdb:1911 Ericsson Business Mobile Networks BV
Bus 002 Device 004: ID 2341:824e Arduino SA
Bus 002 Device 002: ID 8087:0024 Intel Corp......
....

Then create (as superuser) a file /etc/udev/rules.d/50-arduino-mkr.rules with the following content:

#for arduino-mkr1000

2341:824e Arduino SA

SUBSYSTEMS=="usb", ATTRS{idProduct}=="2341", ATTRS{idVendor}=="824e", MODE:="666", GROUP="plugdev"

(the entry beginning with "SUBSYSTEMS ...." should be all in a single line)

Restart your pc.

The MKR1000 should then be accessible via its serial port (something like /dev/ttyACM0 or ..ACM1 etc)

Make also sure that you are a member of the group plugdev.

I hope this helps,
Michael. (here I am, Ballscrewbob ...)

Thanks Michael...

Hey Michael and happy new year,

first, thank you for your reply :slight_smile:
I'm sry that I reply so late (I was not at home over the holidays).

The output of "lsusb" was not helpful.
Only some Lenovo Stuff appeared.

Since my normal laptop only has USB 3.0 ports,
I tested on another machine with Windows10.
At first, it also wasn't working.
But after resetting and using a USB 2.0 port everything worked fine!

You made my day :smiley:

Best Regards
Lukas