MKR1000 sketch upload never completes

I received the MKR1000 as part of the hackster challenge and was able to upload sketches with provided beta libraries. Now that I've upgraded the board library to 1.6.5 it never completes the upload. I have also tried resetting the board during upload. I've tried this on Mac OSx laptop and Windows 10 PC. I've tried both v1.6.7 (on PC) and v1.6.8 (on Mac) of the IDE.

No joy. I was excited to try out the new board for the contest and the beta cloud site, but this stop me cold.

I can provide more detail if necessary.

Have you tried going back to Arduino SAMD Boards 1.6.3? I'm not saying you should give up on getting 1.6.5 working but that would verify that it's definitely Arduino SAMD Boards 1.6.5 causing the problem.

So just after posting this, I switched to another USB port on the Mac, and voila... not sure what the magic ingredient was. Must be I have to post here first.

Also, moderator types - why can we post only once every 5 minutes? Makes it awfully hard to edit posts...