MKR1000 sketches don't upload

Hi,

I used many Arduino boards without problems before. Not sure what I'm doing wrong. Windows 10, connect USB port and COM3 shows MKR1000, Windows shows the device. Appears and disappears as expected when connected and disconnected. Arduino IDE 1.6.9, Board installed via board manager and selected. Libraries WiFi101 installed. Hit upload as usual and it says no device on COM3 after compiling. Board info yields: BN: Unknown board VID: 0403 PID: 6001 SN: Upload any sketch to obtain it

Tried several different sketches and they won't upload. Now what?

I guess it's not the problem, but... Do you properly installed the arduino driver? It could help reistalling it.

mephala.

Did you try to quickly DOUBLE tap the reset button ?

When you do it will show the post as COM x (Arduino/Genuino MKR1000).

It may also list the original MKR COM port but choose the one above.

Yes! The double tap worked (titled bootloader now in Windows). Thanks so much.

You are welcome.

Maybe because I am on win 7 x64 it shows different ?

Its also worth updating your cores too for the M0 and MKR via board manager. MKR is currently 1.6.4-mkr02 and M0 is 1.6.6 (not to be confused with the IDE)