MKR1000 WiFi module not detected

Hello all,

I just got an MKR1000, and after testing the simple AP example successfully, I tried using it to control a differential motor car. Something went wrong and it indicated that the upload had failed, so I tried again (though I need to double tap reset every time I want to upload anything)

I noticed that even when an upload was successful, the rutin would get stuck after printing "creating access point" (this is using the example as is), after some troubleshooting I saw that the issue is that it couldn't resolve the following part of the code:

// check for the presence of the shield:
if (WiFi.status() == WL_NO_SHIELD) {
Serial.println("WiFi shield not present");
// don't continue
while (true);
}

To try and solve the issue I checked again what was the firmware and wifi101 library versions, but the odd thing is that it seems like the wifi module is not present at all. So the results i get look like this:

12:05:18.907 -> WiFi101 firmware check.
12:05:18.907 ->
12:05:18.907 -> WiFi101 shield:

I don't have a bootloader, but I'm considering buying one to see if I can get it to work again, but if any of you has any suggestions of what I could try in the meantime I would really appreciate it.

What do you mean by "a bootloader"?