MKR1010 OTA IDE does not show Network Port

My sketch uses ArduinoOTA.h ver 1.0.6 and WiFiNINA.h ver 1.8.10
The MKR firmware was updated for WiFiNINA 1.8.10
The IDE 1.8.15 is running on MacOS 10.13.6 on a 2018 MacMini.
The Mac is using Ethernet to connect to the wifi router and the MKR is using wifi to connect to the router.
When I first use the IDE to upload my sketch via USB, after the upload is completed and the MKR boots up and connects to my local wifi network the IDE displays the allocated local 192.168.x.x ip address. At this point I can disconnect the usb from my Mac and upload successfully new sketches via the wifi ip network port.
However after several days(?) I find that the IDE can no longer see the MKR's wifi ip address.
I can ping the MKR successfully from a Terminal and the sketch is continuing to execute and upload data to Thingspeak. Other devices connected to my local wifi are functioning normally.
Reloading the IDE does not find the MKR wifi net port.

Powering off/on the MKR results in the IDE rediscovering the MKR's wifi network port, but this requires intervention by other means to perform the power off/on and defeats the purpose of OTA!

Does the IDE need to be on continuously to maintain the IP port connection?

Is there a library function that the MKR sketch can use to test for loss of the port and reconnect to the IDE and maintain the OTA function?

https://github.com/jandrassy/ArduinoOTA#ota-upload-from-ide-without-network-port

Thanks, I have installed the my_boards library edited with my local ip address and restarted the IDE.

my_boards is not a library. it is a repository with my customized boards. for you it is an example on how to customize configuration for your boards.
for MKR it would be enough to apply the "If you don't want to use my_boards ..." part of the "OTA Upload from IDE without 'network port'" section.

I have attempted to follow the directions in the "If you don't want to use my_boards ..." part of the "OTA Upload from IDE without 'network port'" section however after restarting the IDE my Tools menu is unchanged. I do not


get the "Arduino OTA (...)" option in the Tools menu.
Am I in the correct directory location for platform.local.txt and my edited programmers.txt files?

in "Programmer" submenu?

See screen shots, files attached

Screen Shot 2021-07-25 at 8.44.35 am.png

(Attachment platform.local.txt is missing)

(Attachment programmers.txt is missing)

Programmers.txt

arduinoOTA24.name=Arduino OTA SAMD (192.168.100.24)

arduinoOTA24.program.tool=arduinoOTA

arduinoOTA24.ip=192.168.100.24

platform.local.txt

# This configuration file supports the general ArduinoOTA library https://github.com/jandrassy/ArduinoOTA

## arduinoOTA as programmer. add entries with {ip} into programmers.txt

tools.arduinoOTA.cmd={runtime.tools.arduinoOTA.path}/bin/arduinoOTA

tools.arduinoOTA.program.params.verbose=

tools.arduinoOTA.program.params.quiet=

tools.arduinoOTA.program.pattern="{cmd}" -address {ip} -port 65280 -username arduino -password password -sketch "{build.path}/{build.project_name}.bin" -upload /sketch -b

did you really restart the IDE. didn't some window hold the instance open?

I have now restarted the Macmini with no change to the Tools/Programmer menu.

The only file that I have added to the IDE is the file from github ArduinoOTA/extras/samd/ platform.local.txt.
And I have edited by adding in the programmers.txt 3 extra lines

arduinoOTA24.name=Arduino OTA SAMD (192.168.100.24)
arduinoOTA24.program.tool=arduinoOTA
arduinoOTA24.ip=192.168.100.24

Again am I in the correct IDE folder samd/1.8.3 and are there any other files/folders, Board Manager libraries which I need?
I have not previously edited/added any files to the IDE except via Library and Board Manager.

I even tested it now again (on Linux) and yes that is all.

maybe @pert can help. Per, could you please take a look. the files are in the right location, but IDE doesn't show the additional programmer

could it be some wrong line endings problem with the copy pasted lines?

Hello! Which board do you have selected from the Arduino IDE's Tools > Board menu?

There was a change in Arduino IDE 1.8.13 that made it so only the programmers defined by the platform of the currently selected board are shown in the Tools > Programmer menu. Previously, all programmers of all installed platforms were shown there so it would show up no matter which board you had selected.

I added those lines to the programmers.txt file of my Arduino SAMD Boards platform programmers.txt and I now have the expected new Tools > Programmer menu entry:
Clipboard01


Unrelated to the issue with the programmer, but is there a particular reason for using Arduino SAMD Boards 1.8.3? It is 1.5 years out of date. There were some big changes at 1.8.10, which ended up inadvertently breaking a few 3rd party libraries, but I think up to 1.8.9 at least is safe, and even 1.8.11 is going to work fine for 95% of people.

1 Like

MKR1010 is selected board.
Boards Manager has installed Arduino SAMD Boards (32-bits ARM Cortex-M0+) ver 1.8.11
My IDE is 1.8.15 installed in macOS Applications
The Readme on Github jandrassy/ArduinoOTA says
"If you don't want to use my_boards, the platform.local.txt files for avr and samd in extras folder in this library contain the configuration for arduinoOTA tool as programmer. Copy platform.local.txt next to platform.txt in the hardware package of your board."
Where is this hardware package for IDE 1.8.15?
I used Google to search for the hardware package. I was directed to Arduino15. Spotlight found Arduino15. It is in my Home Safe View folder!!!?

This does not appear to me to be the correct place for the platform.local.txt file and the edited programmers.txt file.

Where in the IDE do I find the correct programmers.txt file to edit?

Ah, I see now. The file you are editing is under this "HomeSafe View" folder, which is not likely to be the one the Arduino IDE uses.

  1. Start the Arduino IDE
  2. Select File > Preferences from the Arduino IDE's menus.
  3. Click the link on the line following "More preferences can be edited directly in the file". This will open the C:\Users\{username}\AppData\Local\Arduino15 folder. It was convenient to access it via the Arduino IDE because the AppData folder is hidden by Windows File Explorer by default, making it difficult to navigate to normally.
  4. Navigate to the packages\arduino\hardware\samd\1.8.11 subfolder of the Arduino15 folder.
1 Like

Success. Thanks to all.

The Library folder in my macOS was hidden. It contains the current Arduino15 folder and samd folder1.8.11

The HomeView Safe folder also contains an older Arduino15 folder! Which should be deleted?

I'm glad to hear it's working now!

Oops. I forgot the folder is also named Arduino15 on macOS. I assumed Windows when I saw that, since it is named .arduino15 on Linux.

What is this "HomeSafe View" thing? A Google search indicates it's a security camera app, but that doesn't seem very relevant.

1 Like

I have video camera security by Swann.
There are some apps which I only use on my iphone/ipad.
I recall at the time of the camera installation an attempt (which was not successful) was made to install the app on my macmini. it is easier to use a hdmi monitor switch to access the video system if I need to log into it.
Hence the HomeSafe View folder was probably created but how did an earlier Arduino15 get installed in it??