MKRWiFi1010 port not showing up

I purchased two MKR WiFi 1010 boards where the first one had a wifi signal strength issue and the other one doesn't show up under ports on my MacBook Pro 16". I tried installing hourly/beta builds for the arduino app and arduino IDE. I tried 6 different usb cables and bought new ones from Amazon with USB-A and USB-C connectors, switching usb ports on the laptop. None of them works with the second MKR WiFi 1010 board - the first one did work but had the wifi issue.

The board lights up correctly when plugging it in, but it does not show up under ports at all. I even tried it with a windows desktop pc where it did not show up as well. Anyone any ideas? Is there anything else I can try?

Hi @unisonmuc

Have you tried double tapping the reset button two times in quick succession?

This should put the board into bootloader mode. From there you should be able select the bootloader COM port from the Arduino IDE (Tools->Port->COMx) and upload as normal.

Hey there. Thanks for the reply. Yes I did try that and the built in led starts pulsing, but it still doesnt show up.

@unisonmuc Try and install the Arduino SAMD Boards package core for the board, see www.arduino.cc/en/Guide/Cores. Use a good quality data USB cable and do not use a USB hub or USB 3.0 port.

@dozie I did install the Arduino SAMD Boards and also tried uninstalling and reinstalling them - no luck. Are the USB type C ports on a 16" MacBook Pro USB3.0? i tried tons of cables and bought new ones as well with none of them working. Is there any recommendation on what type of cable/manufacturer/plug type works best?

Use a good quality data USB cable and do not use a USB hub or USB 3.0 port.
With a good data cable, try the step below:

Put your board in bootloader mode by double tapping the rest button (the onboard L LED will fade in and out slowly). While it is in this mode, upload an example sketch from the IDE, say BlinkLED into it, if upload is successful, then tap the rest button once afterwards to exit the bootloader mode.
Now upload the same sample code normally to the board without double tapping the reset button, if successful, your board can now be programed with your own code normally.
Note: do not use your own code when the board is in bootloader mode.

I went through different 10 USB cables by now and testing it on both my Mac and Windows PC.

Putting the board in bootloader made the LED fade, but when trying to upload a sketch it failed with the error message that no board is detected. What was interesting is that the USB port on the Arduino was sitting slightly tilted to the left, which was not the case with my first MKR1010.

I ended up returning the board and ordering a new one. Hopefully it works out this time, but so far 2/2 MKR 1010 boards failed for me.

Got my replacement board. Everything works perfectly now with a replacement board. My experience with the MKR 1010 is that I had two defective boards. My advice to everyone with problems is: get a good usb cable and don't waste too much time on troubleshooting since they seem to have issues quite often in my case.