MKRZero doesn't work with libraries working with Nano

Hi everyone :slight_smile:

I’m new here (French guy, sorry for the mistakes :slight_smile: ).
I’ve purchased an Arduino MKRZero recently and tried to run some sketch on it.

In particularly, I used, for exemple, the librairie SD.h which worked.
But, I’ve also tried I2Cdev.h , u8glib.h , SoftwareSerial.h or SomeSerial.h which didn’t worked.

Here is the error I have for I2Cdev, in the file I attached.

If someone could help that would be very kind :smiley:

Thanks in advance et have a good day :slight_smile:

That would be because they use different cpu's and one architecture is not the same as the other.

You would have to use the lib meant for the MKR and not the NANO.
There may also be other changes in those libs too to be aware of.

Hi, thanks for your response.

I've been searching for example about Arduino Zero because they use the same CPU if I understand well.
I tried this one for the serial:

But it don't really works. I'm continuing my reasearch and if I can bring an answer I'll tell you.