MODBUSMASTER library not working

I am running basic code of modbusmaster library for reading a holding resistor. At other end I am using modbus slave software as slave. Software is showing that arduino through rs485 to TTL sending correct request queries also software slave is responding with queries but i am not able to get the values .. i am getting timeout error.
Please help.
I had got this working few days ago. Now I am not able to get it working. I changed the module too.

Please post your code. Please post a wiring diagram.

Your topic has been moved to a more suitable location on the forum. Installation and Troubleshooting is not for problems with (nor for advise on) your project :wink: See About the Installation & Troubleshooting category.

Solved! I brought new rs485 to TTL module.. it is working fine! Like it worked before. Don’t know what happened to module. It was behaving strangely.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.