moteur ou driver cassé ???

C'est un moteur pour imprimante 3D 42A02C 42 Ncm donné pour un courant de 1.5A, mais je ne constate qu'une consommation de 480 mA à vide sous 9V (ça dépend peut être du réglage du potentiomètre du driver).

◆ Modèle de produit : 42A02C. ◆ Courant nominal : 1,5 A. ◆ Résistance de phase : 2,4 Ohm ± 10 %. J'en déduis pour l'arrêt: ◆ Tension nominale : 1,5 A * 2,4 Ohm = 3,6V

A partir de la tension d'alimentation, le driver hache le courant pour donner au moteur ce dont il a besoin. Si on est en très basse vitesse, on peut voir le driver comme un régulateur à découpage. Si on part de 9V et que le moteur est de 3,6V, le courant appelé sur le 9V sera 9/3,6 fois plus faible que dans le moteur. Si le moteur est un 1,5A, le courant sur l'alim est de 600mA.

On peur regarder les puissances. Si on prends X watts sur le 9V, et su le driver a un rendement excellent, le moteur recevra X watts.

Sinon, oui cela dépend très fortement du réglage. Si on règle le courant dans le moteur à 0,75A on aura aussi deux fois moins de courant appelé sur le 9V.

mes moteurs ils consomment en tout plus que 3A

Il manque le schéma et comment est fait le réglage pour répondre.

vileroi: Il manque le schéma et comment est fait le réglage pour répondre.

Quel schéma tu veux dire le montage des drivers et des moteurs ??? cdt

Il aurait peut être fallu commencer par ça

si vous voulez dire le montage il y a des photos sur le forum https://www.webastro.net/forums/topic/189761-motorisation-double-axe-pour-monture-new-polaris-avec-moteur-de-map/?tab=comments#comment-2854830http:// il faut aller en bas de la page pour avoir les dernières photos du montage dont on parle si vous en voulez d'autres n'hésitez pas cdt

Dans ce qui suit, je prends des modèles idéaux. Dans la vraie vie, c'est un peu moins catégorique.

Quel schéma tu veux dire le montage des drivers et des moteurs

Oui, et surtout la présence des condensateurs qu'il est recommandé de mettre près des drivers, leurs valeurs, la place du fusible, son type. Pour un moteur 1,5A, 3V (pour simplifier) monté sur une alim 9V le driver va tirer en moyenne 0,5A sur l'alim. Mais, il va pendant 1/3 du temps tirer 1,5A, et 2/3 temps rien du tout. En moyenne il tire bien les 0,5A. Pour le moteur, pendant 1/3 du temps il sera sous 9V et verra son courant de 1,5A. Comme les commutations sont rapides, on peut considérer que le courant n'a pas le temps de varier. Pendant 2/3 du temps il est en roue libre, mais comme les commutations sont rapides, on peut considérer que le courant n'a pas le temps de varier non plus. Il voit donc un courant quasi constant de 1,5A et il est content.

Si on met un condensateur juste avant les drivers, il sert de réserve d'énergie, et c'est lui qui fournit les variations de courant pour le driver. Après le condensateur, le courant vaut soit 1,5A soit 0A. Avant le condensateur, le courant est constant et vaut 0,5A.

Si il n'y a pas de condensateur avant les drivers ou si la valeur est trop faible, la réserve d'énergie se fait grâce au condensateur de l'alim.

Si on met un fusible avant le condensateur qui fait la réserve, montage normal: Alim - fusible - (driver+condensateur) - moteur on a alors un courant constant de 0,5A dans le fusible

Avec 3 moteurs et peu de chance, on peut alors avoir des pointes de courant de 4,5A.

Si on met un fusible après le condensateur qui fait la réserve, montage déconseillé: (Alim+condensateur) - fusible - driver - moteur on a alors un courant qui vaut 1,5A ou 0A dans le fusible

Si on est dans le deuxième cas: - avec un fusible rapide de 3A, avec des pointes de 4,5A; il saute. - avec un fusible temporisé de 3A, il verra que la moyenne 1,5A et il tient.

Conclusion: si tu as un problème, même si pour toi c'est évident, donner le schéma complet, la référence des composants, le code complet, les réglages complets n'est pas inutile. D'autres peuvent voir des erreurs que tu ne soupçonnes même pas. Sur la photo de @manu69, il y a bien des condensateurs, mais @manu69 et @astronomy n'est pas la même personne, et il peut y avoir des différences. D'ailleurs sur celui de @manu69 il n'y a pas de fusible. Perso, un bon schéma peut être fait avec un papier et un crayon. Ce n'est pas l’esthétique qui compte, c'est le contenu.

Je viens de penser aussi à ceci: si tu as bien mis les condensateurs, lors de la mise sous tension, ils vont se charger d'un coup et peuvent appeler un fort courant qui peut faire sauter le fusible.

Donc il ne devrait pas mettre de consentateur

vileroi:
Dans ce qui suit, je prends des modèles idéaux. Dans la vraie vie, c’est un peu moins catégorique.
Oui, et surtout la présence des condensateurs qu’il est recommandé de mettre près des drivers, leurs valeurs, la place du fusible, son type. Pour un moteur 1,5A, 3V (pour simplifier) monté sur une alim 9V le driver va tirer en moyenne 0,5A sur l’alim. Mais, il va pendant 1/3 du temps tirer 1,5A, et 2/3 temps rien du tout. En moyenne il tire bien les 0,5A. Pour le moteur, pendant 1/3 du temps il sera sous 9V et verra son courant de 1,5A. Comme les commutations sont rapides, on peut considérer que le courant n’a pas le temps de varier. Pendant 2/3 du temps il est en roue libre, mais comme les commutations sont rapides, on peut considérer que le courant n’a pas le temps de varier non plus. Il voit donc un courant quasi constant de 1,5A et il est content.

Si on met un condensateur juste avant les drivers, il sert de réserve d’énergie, et c’est lui qui fournit les variations de courant pour le driver. Après le condensateur, le courant vaut soit 1,5A soit 0A. Avant le condensateur, le courant est constant et vaut 0,5A.

Si il n’y a pas de condensateur avant les drivers ou si la valeur est trop faible, la réserve d’énergie se fait grâce au condensateur de l’alim.

Si on met un fusible avant le condensateur qui fait la réserve, montage normal:
Alim - fusible - (driver+condensateur) - moteur
on a alors un courant constant de 0,5A dans le fusible

Avec 3 moteurs et peu de chance, on peut alors avoir des pointes de courant de 4,5A.

Si on met un fusible après le condensateur qui fait la réserve, montage déconseillé:
(Alim+condensateur) - fusible - driver - moteur
on a alors un courant qui vaut 1,5A ou 0A dans le fusible

Si on est dans le deuxième cas:

  • avec un fusible rapide de 3A, avec des pointes de 4,5A; il saute.
  • avec un fusible temporisé de 3A, il verra que la moyenne 1,5A et il tient.

Conclusion: si tu as un problème, même si pour toi c’est évident, donner le schéma complet, la référence des composants, le code complet, les réglages complets n’est pas inutile. D’autres peuvent voir des erreurs que tu ne soupçonnes même pas.
Sur la photo de @manu69, il y a bien des condensateurs, mais @manu69 et @astronomy n’est pas la même personne, et il peut y avoir des différences. D’ailleurs sur celui de @manu69 il n’y a pas de fusible.
Perso, un bon schéma peut être fait avec un papier et un crayon. Ce n’est pas l’esthétique qui compte, c’est le contenu.

Si je mets des pseudos différents
mais sur webastro je suis bien @man69
j’ai mis un fusible dans la prise allume-cigare
je vais essayer de vous faire un schéma au mieux
en attendant MERCI
cdt


Voilà j’espère que c’est assez clair pour vous j’ai fait au mieux

https://cjoint.com/data/KAytTz4mMCv_capture-d%E2%80%99%C3%A9cran.pnghttp://

merci
cdt

Donc il ne devrait pas mettre de consentateur

Si, mais sans fusible ou avec un fusible retardé. C'est rare de mettre un fusible après une alimentation. Si on ne met pas le condensateur, on risque de voir la tension moteur chuter lors des commutations.

vileroi: Si, mais sans fusible ou avec un fusible retardé. C'est rare de mettre un fusible après une alimentation. Si on ne met pas le condensateur, on risque de voir la tension moteur chuter lors des commutations.

Pourquoi c'est rare de mettre un fusible après une alimentation car tout le monde de l'astro fait l'erreur ça veut dire car en astronomie on place toujours un fusible après l'alimentation et comme ce sont des montures motorisées donc avec moteur et des condensateurs donc je ne devrais pas mettre de fusible je vais tester ça je reçois mon alim aujourd'hui cdt

vileroi: Si, mais sans fusible ou avec un fusible retardé. C'est rare de mettre un fusible après une alimentation. Si on ne met pas le condensateur, on risque de voir la tension moteur chuter lors des commutations.

Non ni pour l'un ni pour l'autre.

Fusible : USB + carte UNO L'alim c'est l'USB et la carte UNO est équipée d'un "polyfuse" qui est un fusible réarmable. Un fusible après l'alim protège l'alim contre les courts-circuits.

Condensateur : Cette idée de condensateur réservoir me fait sourire, cela peut être vrai pour des très faible consommation mais pas avec des courants consommés de l'ordre de l'ampère. La charge d'un condensateur est connue, elle s'exprime sous deux formes Q= It et Q=CU. I courant en apères, t temps en secondes, C capacité en farads du condensateur et U tension au bornes du condensateur. Q est une image du nombre d'électrons que le condensateur peut stoquer . Pour maintenir un courant de 1A il ne faudrait pas des µfarads mais des farads.

Le condensateur filtre les fréquences alternatives. Dans le cadre d'utilisation de ce projet l'alim peut avoir des sauts sur la tension de sortie provoqués par les commutations de courants. Tout dépend de la rapidité de réaction de l'alimentation à une perturbation sur la charge. Une alimentation c'est un asservissement donc PID.

Un saut de tension se traduit par une "marche d'escalier" qui comprends une infinité de fréquences. Le condensateur filtre ces fréquences et lisse "la marche d'escalier" ce qui est déjà pas si mal et c'est pour cela qu'il est indispensable.

Note : Q = It; Q s'exprime en coulombs, I en ampères et t en secondes. Cette quantité rappelle les "A.H". En fait c'est la même chose à la différence près que dans le systême d'unité international, l'unité est la seconde et non pas les heures. Q doit être utilisé pour faire des calculs, et sert pour établir l'équation de la charge d'un condensateur. Les "A.H" sont une unité pratique pour les estimations de temps de fonctionnement sur batterie mais c'est absolument tout ce qu'on peut faire avec.

donc l’alim suffirait ?

Pour maintenir un courant de 1A il ne faudrait pas des µfarads mais des farads

Si je veux calculer la valeur du condensateur, en reprenant la formule C=IT/U, cela donne pour 1,5A, - le toff d'un A4988 est de 30µs et pour l'alim de 9V, il faut laisser passer le courant pendant 1/3 du temps. Le condensateur dit alors maintenir le courant pendant les 20µs restantes - et pour une baisse de tension possible de 1,2V (Alim de 12V, on se permet une chute de 10%), cela donne: C = 1,5 x 20µs / 1,2V = 25µF. Les condensateurs mis sur les cartes sont des 100µF. Pour moi, ils jouent bien le rôle de réservoir et empêchent la ligne d'avoir des courants importants.

donc l'alim suffirait ?

Pour moi, si on ne met pas les condensateurs, cela fonctionne mais avec dans le fil d'alimentation un courant de 2A pendant que le driver conduit, -2A pendant le fast decay, 0A pendant le slow decay, le tout à une fréquence de 33kHz. Avec un condensateur de 100µF, le courant dans le fil de l'alim du driver est quasi constant à 0,5A

Avec ou sans condensateurs on devrait avoir un fonctionnement correct des moteurs, mais dans un cas c'est un émetteur.

[Schéma] Voilà j'espère que c'est assez clair pour vous j'ai fait au mieux

Le lien sur le schéma est très difficile à utiliser. Comme c'est une image, mettre directement l'image dans le texte.

Pour moi le schéma est illisible, Voici un exemple de schéma (on peut le faire avec un crayon, un papier et un scaner ou un appareil photo): Si un fil croise un autre fil, il vaut mieux que ce soit à 90°. On peut aussi mettre des noms aux fils, comme cela est fait au dessus pour step_enable: tous les broches repérées step_enable sont reliées ensemble. On le fait très souvent pour le 5V et le 0V.

Bon j'ai reçu mon alimentation et je n’ai pas mis de fusible tout fonctionne je vais vous reposer une question le driver chauffe à fond et est-ce que c'est normal qu'au bout d'un moment après avoir mis le driver sous tension j'entends un petit bruit comme cccrrriiiiiiiiiiccccck ??? Merci beaucoup encore pour le schéma je vais réaliser un circuit imprimé avec EAGLE j'ai suis non plus pas sûr que les moteurs font correctement leur marche arrière mais c'est possible qu'ils la fassent merci cdt

ce bruit c'est parce que le moteur force

ah bon mais c'est bizarre qu'il force car il est à vide peut-être que c'est les engrenages ??? merci cdt

et tu as mis combien pour la vitesse des moteurs pas à pas ?

dragonard: et tu as mis combien pour la vitesse des moteurs pas à pas ?

1000 pour Stepper 1 et 3 et 500 pour Stepper 2 et 36 pour le suivi c'est Stepper 1 qui gère cela (j'ai mis une vitesse de suivi au pif car j'ai toujours pas fait mes calculs :disappointed_relieved:) merci

cdt

le driver chauffe à fond

Si il est correctement réglé, il fait passer des courants d'1,5A tantôt dans un sens, tantôt dans l'autre. Et si une bobine n'est pas alimentée, l'autre est au maxi. Le pauvre driver n'a pas de repos. Et avec 1,5A, c'est normal qu'il chauffe. C'est pour cela que l'on peut monter des radiateurs dessus.

et est-ce que c'est normal qu'au bout d'un moment après avoir mis le driver sous tension j'entends un petit bruit comme cccrrriiiiiiiiiiccccck

En mode pas, mes moteurs font énormément de bruit. C'est pour cela que je passe en micros pas. Et à l'arrêt, comme le driver délivre un courant ayant une composante variable, bien qu'à 30kHz, je suppose qu'il y a une résonnance quelque part. Chez moi le bruit est différent si c'est le premier micro pas, le deuxième... La résonance peut être différente si le moteur est froid ou chaud.