moteur ou driver cassé ???

Pour maintenir un courant de 1A il ne faudrait pas des µfarads mais des farads

Si je veux calculer la valeur du condensateur, en reprenant la formule C=IT/U, cela donne pour 1,5A,

  • le toff d’un A4988 est de 30µs et pour l’alim de 9V, il faut laisser passer le courant pendant 1/3 du temps. Le condensateur dit alors maintenir le courant pendant les 20µs restantes
  • et pour une baisse de tension possible de 1,2V (Alim de 12V, on se permet une chute de 10%), cela donne:
    C = 1,5 x 20µs / 1,2V = 25µF. Les condensateurs mis sur les cartes sont des 100µF. Pour moi, ils jouent bien le rôle de réservoir et empêchent la ligne d’avoir des courants importants.

donc l’alim suffirait ?

Pour moi, si on ne met pas les condensateurs, cela fonctionne mais avec dans le fil d’alimentation un courant de 2A pendant que le driver conduit, -2A pendant le fast decay, 0A pendant le slow decay, le tout à une fréquence
de 33kHz.
Avec un condensateur de 100µF, le courant dans le fil de l’alim du driver est quasi constant à 0,5A

Avec ou sans condensateurs on devrait avoir un fonctionnement correct des moteurs, mais dans un cas c’est un émetteur.

[Schéma] Voilà j’espère que c’est assez clair pour vous j’ai fait au mieux

Le lien sur le schéma est très difficile à utiliser. Comme c’est une image, mettre directement l’image dans le texte.

Pour moi le schéma est illisible, Voici un exemple de schéma (on peut le faire avec un crayon, un papier et un scaner ou un appareil photo):


Si un fil croise un autre fil, il vaut mieux que ce soit à 90°. On peut aussi mettre des noms aux fils, comme cela est fait au dessus pour step_enable: tous les broches repérées step_enable sont reliées ensemble. On le fait très souvent pour le 5V et le 0V.

Bon j'ai reçu mon alimentation et je n’ai pas mis de fusible tout fonctionne je vais vous reposer une question le driver chauffe à fond et est-ce que c'est normal qu'au bout d'un moment après avoir mis le driver sous tension j'entends un petit bruit comme cccrrriiiiiiiiiiccccck ??? Merci beaucoup encore pour le schéma je vais réaliser un circuit imprimé avec EAGLE j'ai suis non plus pas sûr que les moteurs font correctement leur marche arrière mais c'est possible qu'ils la fassent merci cdt

ce bruit c'est parce que le moteur force

ah bon mais c'est bizarre qu'il force car il est à vide peut-être que c'est les engrenages ??? merci cdt

et tu as mis combien pour la vitesse des moteurs pas à pas ?

dragonard: et tu as mis combien pour la vitesse des moteurs pas à pas ?

1000 pour Stepper 1 et 3 et 500 pour Stepper 2 et 36 pour le suivi c'est Stepper 1 qui gère cela (j'ai mis une vitesse de suivi au pif car j'ai toujours pas fait mes calculs :disappointed_relieved:) merci

cdt

le driver chauffe à fond

Si il est correctement réglé, il fait passer des courants d'1,5A tantôt dans un sens, tantôt dans l'autre. Et si une bobine n'est pas alimentée, l'autre est au maxi. Le pauvre driver n'a pas de repos. Et avec 1,5A, c'est normal qu'il chauffe. C'est pour cela que l'on peut monter des radiateurs dessus.

et est-ce que c'est normal qu'au bout d'un moment après avoir mis le driver sous tension j'entends un petit bruit comme cccrrriiiiiiiiiiccccck

En mode pas, mes moteurs font énormément de bruit. C'est pour cela que je passe en micros pas. Et à l'arrêt, comme le driver délivre un courant ayant une composante variable, bien qu'à 30kHz, je suppose qu'il y a une résonnance quelque part. Chez moi le bruit est différent si c'est le premier micro pas, le deuxième... La résonance peut être différente si le moteur est froid ou chaud.

bonjour merci pour votre aide en ce pendant je voulais m'assurer que tout fonctionne comme voulu puis j'ai donc rebranché l'alim et à partir d'un moment un moteur le Stepper 3 se met à tourner tant dis ce qu'il ne le devrait pas avez-vous une idée ??? un grand merci encore cdt

alors qu'il n'y avait pas d'alim ?!

dragonard: alors qu'il n'y avait pas d'alim ?!

Si, je pense avoir résolu le problème je vais monter mes drivers sur un autre support car les breadboard ne supportent pas cette tension de 12v en +- 5A, ils fondent :confused: je vous tiens au courant merci encore

cdt

ok tu pourrais les souders

De toute façon je vais les fixer avec le fameux support je suis sûr que ça ira mieux en attendant merci cdt

oui essaie toujours. :)

et ça marche ducoup ?

dragonard: et ça marche ducoup ?

je vais voir ça je n'ai plus envie de souder maintenant :sleeping: je vous tiens au courant pour demain cdt

ah d’accord

J'ai monté les drivers sur ce fameux support et les moteurs ne tournent pas ou à peine avez-vous une idée ??? SVP j'ai aussi soudé le 12v comme vous l'avez proposé et là ça marchait mais je ne peux pas les laisser comme ça soudé car c'est pas assez sûr merci cdt

mais je ne peux pas les laisser comme ça soudé car c'est pas assez sûr

Qu'est-ce qui n'est pas assez sûr ? Si tu ne veux pas souder mets des dominos.

Tu as supprimé la beadboard (quelle idée de vouloir faire passer des ampères dans un truc pareil, c'était la gamelle assurée !), c'est bien et j'espère que tu as viré tous les fils Dupont parce que si tu les as conservé ce serait un gag.

Juste pour info regarde le diamètre des fils secteur pour un appareil ménagé qui fait 1kW --> 1 kW en 230V cela fait en gros 4A et fait la comparaison avec ce que tu as utilisé.

68tjs: Qu'est-ce qui n'est pas assez sûr ? Si tu ne veux pas souder mets des dominos.

Tu as supprimé la beadboard (quelle idée de vouloir faire passer des ampères dans un truc pareil, c'était la gamelle assurée !), c'est bien et j'espère que tu as viré tous les fils Dupont parce que si tu les as conservé ce serait un gag.

Juste pour info regarde le diamètre des fils secteur pour un appareil ménagé qui fait 1kW --> 1 kW en 230V cela fait en gros 4A et fait la comparaison avec ce que tu as utilisé.

ok merci c'est pas que je ne veux pas souder c'est que les fils sont trop près et que j'ai du mal à mettre un morceau de scotch je vais voir pour les dominos merci cdt

Bonjour
j’ai essayé avec les dominos et j’ai soudé mais les moteurs ne tournent pas
avez-vous une idée ???
Merci
cdt