Motor control v1.1

I am using v1.1 motor board what should the the output voltage be on the four pins?

The MAX output voltage on the four pins will be the voltage that you put on the Vin pin. If Vin is connected to the Arduino board below the shield, then it is the voltage that you have before the 5V voltage regulator. If Vin is applied externally and not from the Arduino board, then it can go up to 30V if you are using the L293 or compatible chip.

I am getting max of 1.3v. using a 9v adapter through the arduino board. when using this example;

/*

#include <Stepper.h>

// change this to the number of steps on your motor
#define STEPS 100

// create an instance of the stepper class, specifying
// the number of steps of the motor and the pins it’s
// attached to
Stepper stepper(STEPS, 8, 9, 10, 11);

// the previous reading from the analog input
int previous = 0;

void setup()
{
// set the speed of the motor to 30 RPMs
stepper.setSpeed(30);
}

void loop()
{
// get the sensor value
int val = analogRead(0);

// move a number of steps equal to the change in the
// sensor reading
stepper.step(val - previous);

// remember the previous value of the sensor
previous = val;
}

I have applied 9v and 12v sources to the Motor shield at the VIN Grd (using a L293D chip while on top of the Arduino board) and I am still getting no more than 1.3 volts. I am having the same problems with the Adafruit Motor Shield. I also upgraded to the Atmega 328 hoping that this might solve the problem but it has not. Any help from anywhere would be very much appreciated!

I have applied 9v and 12v sources to the Motor shield at the VIN Grd

Have you actually measured that once you apply 12V and it is connected through to the motor that it still measures 12V. It could be that the current draw is too much for the power supply. Also in the above quote I am not sure what the "Grd" refers to and why you are using two voltages?

Sorry, meant to write Gnd. I have tried the two different voltages just to see if it made a difference. The 1.3v stated was with no load. This voltage won't even push a 1.5v DC motor. Do you have an example that I can try that would just push a single DC motor?

The L293 chip should have Vs (pin 10) connected to the power supply to drive your motor and Vss to the logic level supply (+5V on the Arduino). Pins 4, 5, 6, 7 & 14, 15, 16, 17 should all be at ground.

Then if you put Pin 1 (enable) to +5V and Pin 2 to +5V then you should get Vs on Pin 3 (Output 1). Similarly a logic one on Pin 9 gives you Vs on Pin 8 (Output 2)

If you don't it is either the chip is not working or it has been wired up wrong.

Thank you.
I am getting 3.92v on pin 10.

I am new at this and sadly I do not know what the rest of your advice is in reference to;

Then if you put Pin 1 (enable) to +5V and Pin 2 to +5V then you should get Vs on Pin 3 (Output 1).
Similarly a logic one on Pin 9 gives you Vs on Pin 8 (Output 2)

Btw; my email is rdeisen@q.com if you would prefer to continue this off of the forum.

I did not post this to this forum, I also have the Adafruit motor shield and have been having the same problems with that one too. The kicker here is they both worked up until April 9, 2009 when they both stopped doing what they were supposed to do. I have tried getting some info from the Ladyada forum without much success.

This is the thread from that forum: http://forums.ladyada.net/viewtopic.php?f=31&t=10619

Thanks again for your time!

OK I don't think you are telling the full tale here. From the other thread it looks like this was working and it has now stopped but one of the boards might be working again?

What about the green LED, is this only lit when you connect external power to it, was it always lit before?

When it stopped working was it while it was running or was it a case of you change something or wire it up again and it didn't work that time.

All these are very relevant to trying to see what you have done. In general things do not stop working unless they break. They can break because you have not done something or break because they were overloaded and finally gave up.

If from the other thread as you say it stopped working and then it started working again and it is now broken again you are not wiring it up correctly.

I have suspected "breakage" from the beginning of these problems. The part from the other forum that indidcated that the 'duino shield was working was erroneous or an anomaly. I think that I was able to get just enough v's to run a tiny motor, 1.5v for a short time and then all went out the window. I have ordered a couple of new L293E's hoping that that would be the problem but I am guessing :-?

The green light on the 'fruit shield is only on when I have an external power supply on. As to it being lit before things went downhill, I am sure. (I started working with 'duino over a year ago and stopped last April and started again a few weeks back so I am starting from scratch.)

As far as overloading, the motors used have all been between 1.5v and 9v with none reaching past 500ma. I have also been very careful with wiring, doing so correctly and also making sure that I have disconnected all power supplies before making any wiring changes. (Count this as lessons learned the hard way last year)

I have ordered a couple of new L293E's

I thought these were surface mount parts are you sure you have the tools to fit them?

It sounds like you had a short in the motor and that blew the drivers.

On the duino board I have "plug-in mounts" (I am not sure that is the correct term) so it is just pop out an push in. The Adafruit IC's are soldered in so those will present a small challenge but I've done this before. I found an L298N in my stash but have not had a chance to research that yet.

Thank you for your advice!

I ordered the wrong IC, L293E, it is a 20 pin. waiting for the correct one now. Any advice on making a Atmega 328 work on a Diecimila?

Not surface mounts, the are DIP.