Motor shield broken?

Hi all, I´ve been using an Arduino for a while now, but I´m running into some problems.

I got a DFRobot motorshield (Arduino_Motor_Shield__L293___SKU__DRI0001_-DFRobot) connected to my Arduino, and 2 lego motors to the shield. I connected the shield and motors just the way it should, so there is no problem there.

Whenever I set the directional port of Motor 2 (pin 4) to LOW, the motor doesn't do anything. If I do the same for Motor 1 (pin 7) the motor does turn the other way.

My best bet is that the shield is broken, but I'd like to know what you guys think.

Have you swopped the motors onto each others' pins?- that way you could check if it's the board or the motor.

Yep, tried that. Then the other motor gives me problem. So the motors are fine. It isn't the Arduino either, because when I tried the same sketch (Dfrobot demo code) with another Arduino, I got the same problem. Guess I gotta get a new shield :roll_eyes:.

Can you show your connection diagram? We will try to help you solve the problem.