Motor shield Help

So im using a motorshield and it works just fine with Arduino uno, but only 2 motors drive instead of 4 when connected to arduino Mega.

tried to power the shield and the board separately and it still doesnt work.
the ones the arrows point towards are the one that wont drive.
using the standard code to teach you how the motorshield works.
plz help :stuck_out_tongue:

Your biggest problem there will be the battery (9v square) which is almost useless for those types of application.

Maybe try a bank of AA or a rechargeable battery pack to start with.
Not sure why you also need two different battery packs ?

i am doing that with my main battery as you can see.... i read somewhere that it could be a problem that they arent charged seperately... i tried to do that and it still didnt work.... so ignore the other battery atm :stuck_out_tongue: was just to check if it worked but it didnt so... and idk why it wnot work when it works just fine with the arduino uno... any ideas`?

I’d guess a wiring error or the Mega needs a bit more juice than the Uno and that battery can’t hack it. Easy to test. Put the robot up on blocks & power the mega from whatever computer you’re using to program it.

I see that you are using the same shield I used.
Please see my #12 post below, which I believe will be useful.

You may need to activate the PWM0A and PWM0B pins,
which I beleve are related with the H bridge for M3&M4 motors.