Motor shield

hi,
when i connect my motor shield to my arduino and i initialise motor on channel 'b'.The arduino uno's pin 13 led below the shield blinks when my B channel is on.what is the problem.how can i rectify it.
thnx

Why is a blinking LED a problem?

You have not told us exactly what shield you are using - post a link to its datasheet.

You have not posted your program.

...R

hi,
see,i will tell you my problem.i have coded it right ,the motors are working as desired .i am using original arduino motor shield.the problem is the led on my arduino uno is blinking when i connect my motors to chanel"b".is it ordinary or a problem.

and i have another problem ,i had connected my 9v supply to arduino motor shield but when i remove my usb cable from arduino uno ,the arduino is still on.is it ordinary or a problem.
thnx

Please don't SHOUT.

Please provide the details requested in Reply #1. It wastes everyone's time having to ask twice.

...R

hello,

fyi-

here’s my code:

void setup() { 

 pinMode(12, OUTPUT);
pinMode(13,OUTPUT);

}

void loop()

{


 digitalWrite(12, LOW);
 analogWrite(3, 250);
 delay(1000);

 digitalWrite(13, LOW);
 analogWrite(11, 250);
 delay(1000);

 

}

i am using arduino motor shield(original).

i didn’t mean to say whether blinking led is a problem on arduino uno.is it ordinary or a problem.or it is taking power from pin 13 led on board for blinking.

i have the problems mentioned in reply#3.

i am new to this forum.

thnx

SORRY ,I HAVE THE PROBLEMS MENTIONED IN REPLY#2.

I DIDNT KNOW HOW TO SEND CODE.SO I DID THIS WAY.

THNX

Your caps lock key is stuck.

I HAVE THE PROBLEMS MENTIONED IN REPLY#3.

.. and we have the problem with your shouting as already mentioned in reply #2

I AM NEW TO THIS FORUM.

This is no excuse

  1. to SHOUT
  2. to not having read the forum rules, which would have given you all instructions:
    what information to be provided in which way.

This is a very supportive forum and a lot of experts are ready to assist.
But: it's now your turn to follow those instructions to bring YOU into the position that WE are willing to support you.

HARI6:
I AM USING ARDUINO MOTOR SHIELD(ORIGINAL).

I don't have one of those. If, as requested, you post a link to its datasheet I can read that to see if I can help you.

...R

Hi HARI6, and welcome.

Didn't you do other sketches before learning how to control motors ?
Don't reply to this question because we already know the answer.
You need to learn the basics first, and when you progress you can learn to control motors soon enough.
You skipped the basics part and went straight to controlling a motor, didn't you ?
If you would have taken some time to learn and do the examples that come with the Arduino IDE (meaning do something more than just load it into your Arduino, so you actually learn to understand what's going on), you 'd have recognized what's going on.

Hello,

so should we not use delay function.

heres the link to its data sheet: L298 - Dual Full Bridge Driver - STMicroelectronics

The link in Reply #10 is to the datasheet for the L298. What I would like to see is the datasheet for the shield so I can see the how it connects to the Arduino and how it is intended to be used.

...R

Hello,

this is the website of my shield: Arduino Motor Shield Rev3 — Arduino Official Store

you can find the data sheet here.
thnx

Hello,

My arduino gets heated up sometimes when i connect my motor shield.The component below the usb port gets heated when i connect my shield .I dont know what is the problem.

Why have you started another Thread about the same project? I will not be reading it. Keep all the stuff here.

...R

Having looked at the schematic from the link in Reply #12 it seems that pin13 on the Uno is being used for DIRB and that may account for the flashing.

...R

Hi.

I didn’t tell you not to use delay in this thread, but i’m telling anyone who reads any of my posts to avoid using delays.
Of course there’s good reasons or excuses to use delay, but in most cases you’ll be better of without it.
You should take notice of so called sign off messages, footnotes placed at any and all posts by that user.
My sign off message contains answers to 2 common problems, and a hint to a part of the forum in my native language.

Now, there is a link to this thread and my sign off message, but that is coincidentally.
If you have a close look at the blink without delay sketch, you will find the prove of Robin2’s last post in that code.
So compare these codes and get convinced that this isn’t a problem, but actually a feature.

You should have asked this in your other thread.

Some of the relevant info is already there.

How do you power the shield and the Arduino.
Post a diagram.

You must power this shield externally.
Not possible to power the Arduino plus shield from USB. That will most likely fry Arduino's 5volt regulator.
Voltage/current of the external supply depends on the motors used.
Post a link to the motors.
Leo..

You seem to have two threads about your motor shield. I merged them for you.

How to use this forum

Hello,
I have a problem with my servo motor i.e it is not accurately going 90 degrees .Only if i put 80 degrees in the code it is going 90 degrees.what seems to be the problem here.
thnx