MPR121 capacitive touch sensor mystery

I'm wondering if any of you have had the chance to play with Sparkfun's capacitive touch sensor breakout board based around the MPR121 chip: http://goo.gl/BsGD (MPR121 datasheet here: http://goo.gl/g5i9).

Yesterday I hooked it up with the MPR121 code found on this blog: http://goo.gl/1j7N, and it worked flawlessly from the first time I plugged it in. But today it simply stopped acting properly.

My problem is basically this: the electrode itself (in my case a simple piece of connective wiring in a breadboard) - be it touched or not!! - is putting up a positive touch status flag all the time it's connected to any of the pins of the breakout. The breakout works fine and as expected - as long as I don't connect anything to the electrode pins, which kinda defeats the purpose of the breakout. :D

Example:

If the breakout is just plugged into the breadboard and I brush my fingers on the 4 solder connections of pins ELE0-4, the sensing acts as expected (I serially output the result and get binary 1111 for all 4 touched pins, 1101 for pins ELE3, ELE2 & ELE0 together, 101 for pins ELE2 & ELE0 together, just 1 when I touch ELE0 etc.). As soon as I release touch on any of the pins, that bit falls to 0 as expected. Everything fine there, and everything exactly as yesterday.

However, when I want to extend the electrode away from the pin with a wire and I plug the wire next to pin ELE3, I'll immediately get a 100 response (even with the wire let go). If i plug in all 4 wires, I'll get 1111. If I plug in all the 12 electrodes, I'll get 111111111111. If I then pull any of the wires out, the corresponding bit falls back to 0 immediately.

I repeat, the wires are not being touched. It's just like I soldered a very long pin to the breakout and left it alone.

I'm completely confused because yesterday it worked flawlessly not only on the same breadboard and with all 12 wires hooked up, but with a full-blown touch sensing prototype maid of tin foil, LEGO's and stuff. Even proximity sensing worked great.

I've checked the wiring at least 50 times in the last 24 hours, went trough the datasheet at least 10 times... No clue as to what I might have done wrong.

Any ideas (other than a f*cked up chip)? Grounding issues (it's grounded, darn it)? Threshold issues (didn't change the registers, why were the thresholds okay yesterday)?

didn't change the registers, why were the thresholds okay yesterday)?

Because it is not a robust technique and just a demo sort of thing without a PCB as the sensor.

Have you wired the board to 3v3 or 5V?

Have you wired the board to 3v3 or 5V?

3v3.

Tomorrow I'll solder some header pins to a replacement MPR121 breakout, and give it a go on a clean breadboard from scratch -- so I can rule out chip failure.

However, I'm always more sure that the problem exists between keyboard and chair than in the hardware -- that's why I'm asking here first. I never underestimate my own stupidity. :-?