MPU6050 Doesnt get detected

I have a mpu6050 sensor but it doesnt seem to be working with the mpu6050 library of jowberg and even jarzbski. When I used the I2c scanner code from the examples it detected the MPU6050 succesfully at 0x68(ADo LOW). Any help will be good.

Please post the sketch that you say does not work

Help us help you by posting your code, as per post#2, and post a few images of your setup powered up.


sorry for bad quality the camera is not proper. But anyways my plan was to build a joystick and gyro controlled rc car , but then I started getting these stupid MPU6050 error messages.
Jeff's library > MPU60505 > Examples > MPU6050 DMPU6
Jowberg's library > MPU6050-Master > Gyro_Simple



Hi,
You best attempt at showing us your project would be to draw your circuit with pen(cil) and paper, make it fit on an A4 sheet and photograph it full frame.

Make the pen(cil) nice and dark to give us some contrast.

Thanks.. Tom... :smiley: :+1: :coffee: :australia:

Ok will do

Still waiting for the code in code tags, not pictures of code.

Hi,
We need more detail, what are the circled items, labels?

Draw a box to represent the 6050 and show wires going to it from the controller, labelling the component and pins.
As asked before, please your code.
To add code please click this link;

Thanks... Tom.. :smiley: :+1: :coffee: :australia:

That far right pin of the square diagram(MPU6050) is the interrupt pin. the big rectangle is the arduino nano and the AD0 pin is set to LOW for 0x68

Here is the link on the official github page for the example I used.

Hi,
Have you tried 4k7 pullup resistors on each of the two I2C data lines?
i2cpullups

Tom... :smiley: :+1: :coffee: :australia:

No I will try it.

Ok so i have tried the TinyMpPU6050 library by Gabriel-Milan.

And it works properly takes about 20 seconds to properly calibrate but then it works without the 4k7 resisitor. Thank you guys for your help though.