mrk1000 can not connect to Arduino IOT cloud to set up new device

Hello all,

I am new here and I hope this post is ok.

I am brand new to Arduino and purchased a few new boards from Amazon a few days ago. I want to set up a MRK1000 on the Arduino iot cloud. I created an account and clicked add a new deivce. I selected the first box, mrk1000 and it ask for a name and I entered PASS and selected new device on the drop down.

I get this following screen.

We could not find any Arduino device
Are you sure you have a device connected to your computer? Do you see at least the power LED on your device lighting up?
You can also try unplug and replug your board again, or try to connect your device with another USB cable.
TRY AGAIN

I have searched for help and tried a few but some of this I don't understand as this is my first time.

Here is some of the steps I have tried.

  1. I downloaded Arduino IDE on windows 10 PC

I installed and ran this app and I noticed a black box on bottom to update libraries. So I opened and installed several Libraries in the recommended and a few under Arduino but I have no idea what they do yet.

I clicked on port and my MRK is listed under PORT 6 So I selected that and it connected. I looked at a few starter examples and selected blink, and loaded it onto the mrk1000 fine. No issues. So it appears the mrk1000 is working as expected.

  1. I closed the IDE, disconnect the mrk1000 from USB and opened chrome on Arduino IOT CLoud. Clicked new device and when it gets to setup device it asked me to install a chrome extension which I did. It is called Arduino Create. I just followed the instructions. I then said try again but it can not find this board.

  2. I do not have the board pins in the black foam and it is setting in a plastic case on its side.

  3. I found 7 usb cables here in the home and tried each one, all 7 connect fine to the IDE but still no connection or device found on iot cloud.

  4. On the chrome Arduino Create, all 7 cables show my mrk1000 and I can connect to it just like I did on
    the IDE. No Problems

I just want to follow the simple guide from Arduino Iot Cloud to have it turn on and off a LED to learn from this but I can not seem to get pass this point.

If someone here has any suggestions I would love to hear them. As a new person, I think I have tried everything I can find on google to make this connect. I'm old and new to this could be a big factor.

Thank you for you time.
Stay safe

Steve C.

Hello @scaudle,

Allow me to confirm that I am experiencing an identical problem to yours except that my desktop is Ubuntu 20.04. The Arduino IDE lets me upload code to the MKR1000 board that then runs it without issues (i.e. board/port selection in IDE is correct). Minor changes in any sketch from Built-in Examples: Basics are clearly effective after code upload.

Notwithstanding the code upload success, I have tried three different cables but still failed to "Set up an Arduino device" with the same message as encountered by you. Unfortunately, the trouble shooting link seems to be incorrect.

I believe the issue occurs when there are other non-supported "genuine" Arduino boards are also attached to the desktop. If I disconnect ALL other boards then the MKR1000 is detected. This is hardly a satisfactory state of affairs (perhaps the developer of this Arduino interface could be encouraged to use a little more elbow grease) but perhaps it is a temporary workaround that I thought you could leverage to complete the tutorial. It completely deflates my planned use of Arduino IoT Cloud since I normally work with seven to nine boards concurrently mostly through ETH shields from a single desktop.

I could be completely wrong in my rationalization of the workaround. Please correct me as you see fit. Thanks.

Kind regards.