MS Surface Pro 3 Upload Problem

I just got a Surface Pro 3. Everything Arduino seems fine (compiling, the monitor), but when I try to upload the program, I get a write error. THis doesn't happen on my laptop, just the Surface. I checked the driver and com port and can't find anything out of order. THe monitor works fine communication with the arduino. It just won't upload. I wonder if the USB port on the Surface doesn't have enough power to burn the program.

Only need some 10's of mA. USB port supposed to be good for 100mA to start, negotiable up to 500mA.
Doesn't the port power the Uno while you are doing serial monitor stuff? Current needed is no different.

Yes. Powers the board fine. Serial monitor works fine bidirectionally, to. After compiling, upload fails immediately with :
"avrdude: ser_send(): write error: sorry no info avail"

Only with Surface. Works fine with Dell laptop and desktop.

Jim

I think you're the test pilot for this one!

I would guess some driver issue with avrdude and the underlying USB port controller?

Sheesh! "Test Pilot" - like a pilot on a farm? ("pile it here, pile it there).

If it's not hardware, then it must be software, right? I'm not conversant with avrdude, so I can't dig further into this. I'm not sure what happens next, but the folks in the pointy hats will probably fix it if it comes to their attention.

What should I do to move this along?

Cheers,

Jim

Need some one more experienced who has similar hardware to look at it. I only have laptops with WinVista, Win7Pro, and Win8.1 at my disposal for testing.

If your 8.1 laptop works O.K., then maybe it's an issue w/ 8.1 surface. I sent an email to the avr chat group outlining the problem, but have not heard back.

J

Ok, be sure to update here when you find out.

Hi Guys,

I've got a surface pro and a Lenovo thinkpad.

Ive just purchased a Galileo arduino.

However, I've also got a Arduino Uno which I've used on both machines very successfully without any incidents at all. The Uno works fine with the Surface Pro 3 and the Lenovo (Windows 8.1 & 7) respectively.

However, the new Galileo doesn't work at all with either. I'm trying to resolve this at the moment and I've tried it with three laptops so far. It won't even update, so I'm thinking that its the board that has the problem rather than the laptops.

Anyway, if you have any ideas please let me know and I hope my experience with the Uno and the Surface helps you out.

I just tried the surface with another Uno board. No problems. I tried the Surface with the first board with the power plugged in and not. No luck uploading. Either the error or just stuck uploading. The second Uno works either way every time. Not what I'd expect from digital circuitry.

Jim

Hi Jimbluesa,

Actually digital circuitry is actually very fragile, dust, static, incorrect voltage supply, solder in the wrong place can easily fry a board.

Hi Guys,

I've got a half moon smile now. Managed to get the Galileo to update and accept sketches on both the Lenovo and the Surface.

The problem was I need to update the "Gadget Serial v2.4".
You do this by

    • Navigating to the Device Manager and right clicking on Gadget Serial v2.4 NOTE - only available when the Galileo is powered on and connected to the device (laptop).
  1. Navigate to the tools folder:

arduino-1.5.3\hardware\arduino\x86\tools. NOTE if you have installed arduino-1.5.3 in any other director then start your search from that directory.

  1. Click ok and update.

After doing the above I was able to load sketches, however, and the reason I haven't got a full moon smile is the led on pin 13 is not blinking as expected with the blink sketch uploaded.

might be a board problem ?

The answer:

The issue is the Surface USB port. It does not have enough power to drive the upload over any but the shortest cable. When I tried another Uno board that worked, I used a 6" cable. I upload to my project over a 10 ' cable. I've had no problem with my old laptop, but the Surface will not upload to any board I have with the 10' cable. When I use a short cable, no upload problems at all.

The Surface USB port will not even power a dvd drive, so no surprise it cant muscle a sketch onto an Uno.

WOW, you are uploading with a 10 foot lead ? that's pretty long. May I ask why such a long lead ?

No place to put computer closer.