MsTimerTwo.h: No such file or directory

Hi,

Since I wanted to play with the MsTimer2 library (http://www.arduino.cc/playground/Main/MsTimer2), I've downloaded the zip file and decompressed it into arduino/libraries, next to the rest of libraries. Finally, I've checked that the source files were contained into its own subfolder: arduino/libraries/MsTimer2/

Now the compiler complains about the following line in my code:

#include "MsTimer2.h"

saying that the file can not be found... Very weird as I've downloaded and used other libraries and had no problem before.

Thanks in advance for your help.

Try:

#include <MsTimer2.h>

instead of:

#include "MsTimer2.h"

That’s the only #include difference I see in your code vs. the example code.

I tried with #include <MsTimer2.h> too. No difference :frowning:

Thanks.

When installing a new library you need to restart the IDE too as it only sees new libs at startup ...

Done too... no change :-(

I'm running the IDE on Ubuntu. I'll install the Arduino IDE onto a Windows box, just to see if that changes anything.

Thanks again!

I'm having the problem on Windows too.

Anyone using MsTimer2 out there? Which version of Arduino IDE are you running? Mine is 0021.

As a side note, if I copy MsTimer2.cpp and MsTimer2.h into my project directory everything compiles fine.

Thanks again.

Problem solved!

MsTimer2 was included and used in a secondary cpp file within my project. Renaming that file from cpp to pde solves the problem.

Thank you very much.