Multiple Definition errors when compiling code

Hey guys,

I'm trying to use cmagagna CC3000 firmware upgrading utility, but I can't get the code to compile in my IDE. When I try to, I get a lot of 'multiple definition' errors

Example: C:\Users\darudude\Documents\Arduino\libraries\CC3000Patch/wlan.cpp:265: multiple definition of wlan_start' wlan.cpp.o:C:\Users\darudude\AppData\Local\Temp\build2527232136854510734.tmp/wlan.cpp:265: first defined here CC3000Patch\wlan.cpp.o: In functionSpiReceiveHandler(void*)':

The code is located here: GitHub - cmagagna/CC3000Patch: An Arduino sketch to upgrade a TI CC3000 WiFi module to the latest firmware

Could someone do me a solid and see if they can get it to compile? I've been banging my head against the wall trying to figure it out.

I'm using Arduino 1.5.8 BETA, and I do not have any CC3000 libraries installed.
I downloaded the zip file and unpacked it in my project folder as a project. I renamed the folder from "CC3000Patch-master" to "CC3000Patch".
Then I started the Arduino IDE, but because I use 1.5.8 I had to change prog_uchar three times in CC3000Patch.ino
Old : PROGMEM prog_uchar ...
New : const PROGMEM byte ...

After that it compiled.

Tried doing with 1.5.8. Faced the PROGMEM issues like you said, but when I corrected them, I got the multiple definition errors again.

Also if it helps - I'm trying to compile on Windows 8.1. I also tried it on a second 8.1 computer that has never had Arduino installed on it, and got the same error.

With Windows 10 Preview 64-bit and Arduino 1.5.8 BETA. I did the same thing, and it worked.
You might have other things installed, perhaps other CC3000 libraries.

Can you uninstall Arduino, and download the zip-file.
Unpack the zip-file (for example in a folder “myPrograms”) and run the Arduino from its folder. You can put a shortcut to arduino.exe on the desktop (right-click ‘arduino.exe’, Send to Desktop).
You can also download other versions and unpack them, so you can choose which version you want to start.

Check the folder with your projects (it might be in C:\Users<user>\Documents\Arduino), is there some CC3000 in the ‘libraries’ folder ? Perhaps you have to temporarily move to that to another location.