My Boards Keep Disappearing from the Port List [Mac]

Hello all!

This is my first post on the forum. I've had this exact issue twice. Basically, I'm working on projects, uploading dozens of sketches per hour to keep tweaking bugs and whatnot and at some point, the device I'm using just completely disappears from the port it's on. There is no indication of any change I've made that would cause it to disappear.

I am using a Mac running macOS High Sierra. The two boards that have disappeared are an Arduino Leonardo (about a week ago) and an Adafruit Feather Bluefruit 32u4 (today). I was connected by Micro-USB to both. They are both running fine without issue but at some point it disappears and I get the standard error: "Couldn't find a board on the selected port." On one of the uploads where it disappeared, I had merely modified the string within a print statement: nothing too fancy so I'm unsure what would cause the issue.

I had read that the issue might be that the bootloader got overwrtten. I tried to reinstall it on my Leonardo with no luck. I tried other USB ports and other cables but those did not fix the issue. I had been using different programs on each board so it shouldn't be code specific. On each board after they stopped working, they were still receiving power over the USB cable because there was a standard blinking light on each, but the lights that normally indicated whether or not they were processing any data (or sending/receiving) were completely off.

In short my questions are:
1.) What is wrong with my boards?
2.) Am I doing something that causes it?
3.) How can I prevent it in the future?
4.) How do I fix the issues with my current boards (if possible).

Thank you all in advance!