My computer can't see my arduino Uno

Update: After a little bit of more research, I just realised that when I plug the USB cable the L light on the board (pin 13) blinks only three times and then stays on. From what I read it seems that I most likely fired the board. But I would like to know how did this happen so I don't repeat it again!? last circuit I connected is described in my original post below...


So here is the full story... I have an arduino Uno R3 which I bought part of the starter kit. It used to work OK without any problems on my windows 7 64x computer.
Last night it started to give me an error when trying to view the serial monitor saying Port is not available. At that point it was uploading the programs to the board OK but I wasn't able to access the serial monitor. I restarted my computer and it worked OK for a while, before it went back to saying port is not available.

So I followed some instruction I found online:

  • reset the board (the brown button on the board) and upload an empty program - didn't help.
  • Uninstalled the auduino IDE and installed it again - didn't help.
  • rebooted my computer - didn't help.

Here I went and uninstalled all the coms ports I found in the device manager under 'Ports (Com and LTP)'. Now after this point (I think) my computer stopped detecting the board at all by that I mean when I plug in the arduino:

  • The device manager list doesn't show any new devices connected.
  • Windows doesn't make any sound.

So I started to do some common sense troublesshooting:

  • Tried a different computer (Windows 8.1) - didn't detect the board either sound... nothing.
  • Tried a different cable on both computers - didn't help.

I should also say that when I plug the usb cable the ON led on the board (green) is on also the L led (orange) is on.

For completeness this all happened while I was trying to wire up the first Servo project in the Arduino Project Book (Starter Kit). This involves a potentiometer, a servo motor and two 100 micro farad capacitors.That's just in case the capacitors can cause such damage?

Any help/ thoughts will be much appreciated.



Are you showing any errors when uploading? Sounds like a driver issue. Check in some other posts but it sounds like your board is falling under 'unknown'.
If you know how to get to the device manager and see the ports, scroll down to 'universal serial bus controllers'. expand the tree and see is any "unknown" devices are shown.
This is a common if not standard flaw I've found with Arduino that I cant wrap my head around how it hasn't been fixed. You'll need to right click the unknown and update the driver on the listed "unknown" device. Right click and update the driver under properties or as its stated under the first pull-down. You'll need to manually locate the drivers folder within the file location where your latest arduino program software is saved. Manuals will state you need to roll down to a deeper sub folder. But if your running windows 7 as you state just select the driver folder one level up from 'ftdi drivers'. note: don't select the "ftdi folder". most likely this you computer will say your drivers are already up to date. leave the board plugged in and restart your computer with the device plugged in and repeat till you see the arduino recognized under 'ports'. I repeated this and re installed and eventually got mine to work after experiencing the same thing.
best of luck.

If you have some webmail account and can download and burn a Linux live CD then you could check what hows up with Linux. If you can do that I can tell you what needs running.

@wilsonajdesign: Thanks for the thoughts, unfortunately nothing is showing on my device manager. As if I'm not connecting anything at all. No unknown devices nothing.

@ChilliTronix: Thanks I'll get one of those and let you know when I have it. However I'm more worried that my board is broken since windows is not showing any sign of detecting a new device when I plug in the USB cable.

I appreciate that, the idea behind trying Linux is that it will tell you if anything is there without the vagaries of Windows driver signing etc getting in the way.

\you may be right that there may well be a problem with the board.

I got Knoppix running on my machine now, awaiting further instructions :slight_smile:


Run dmesg with and without the board plugged in and see what is new when plugged in (from the terminal) and also do an ls /dev/ to see what devices come up.

demsg: the ouput is the same with and without the board being plugged.
ls /dev/? is this a terminal command? I can do ls which lists the directories. nothing about devices.


Yes the ls /dev/ is a command to be run at a terminal. So is dmesg.

The dev tree is a list of devices. So ls /dev/ will list devices. Do one without then with and see if you can see an extra device.

The fact that dmesg shows no change on plugging in could be an issue. I would expect something unless the board or cable has a real big issue.

ok I don't know why it didn't work first time I tried it. I ran the ls /dev/ now... same output in both cases.

I guess I'll go get myself a new board :(.

Thanks for your help anyway.

Try a new cable first and a different port.