My device does not seem to work properly

My device does not seem to work properly.

I received MKRVIDOR4000 board couples of weeks ago and tried to upload sample sketches.
I've checked USB cable, HDMI cable and host PCs by switching them with another one.

  1. Most cases, Arduino IDE stuck while uploading a sketch, and then failed.

  2. When the uploading was successful, I tried to check if it works as expected. But I did not find any clue to believe that it works properly except for the very basic example (Blink).

  • I expected that HDMI signal is detected by any monitors those support HDMI input by uploading VidorDrawLogo sample. - FAILED (no signal at all)

*. After the failure of some tries, I uploaded UpdateBootloader sketch. - Still the same

Is my experience normal?
How do I know if the device (especially FPGA) is working fine or not?

The quickest test is doubletapping the button. This should result in red LED pulsing and board producing a 640x480 video output on HDMI showing Arduino logo. If that doesn't work you should try this [Solved] FPGA boot loader recovery - MKRVIDOR4000 - Arduino Forum
Please note that what seems to be ide hang-up is just the time it takes to perform verification so if you wait a bit, especially when loading a new fpga image, it should complete without errors.

Thank you for your kind advice!

I have succeeded to see the camera preview and logo.

It is still embarrassing that I cannot see the expected screen a few times among numbers of tries.
I hope the software to be stabilized sooner.