My ESP8266 doesnt show up in arduino

I downloaded the necessary libraries so I can add ESP to the board manager, but when I try to assign port to the ESP it doesnt show up

I tired another ESP same problem, tried 2 other arduino boards (MEGA and UNO) and they worked without any problems and showed up as COM4

When looking at device manger the Arduinos I tried show up ion Ports (COM & LPT) with assigned COMs as they should but both the ESPs show up in Other Devices as USB Serial

Trying different USB ports didnt do anything

Which ESP8266 exactly? Does it have a yellow triangle in windows device manager?

I’m using Wemos D1 Mini and it uses the CH340 TTL-to-USB converter for a which a driver is needed; it can be downloaded from CH341SER.ZIP - Nanjing Qinheng Microelectronics Co., Ltd.. So you need to determine which TTL-to-USB converter is on your board.

If it shows up in Other devices, then it doesn’t have a driver installed.

@xanik Please download the driver by clicking here. Download the driver. Extract the folder, then run the .exe file. Then re-open Arduino and it will work. Hope that helps.