My Ethernet shield not working? Please troubleshoot me. Solved

My arduino + ethernet shield is not working with the ethernet examples in the IDE. Ofcourse I changed the Arduino IP address to match my network. The activity lights on my modem/router and on the ethernet shield are flashing normally. The modem/router LAN interface shows that a it is up and 100Mbps. However the Arduino+Ethernet shield doesnot show up in the list of devices in the LAN. Only once the ethernet seemed to work. It was with the NTP time example. But after, it never worked. The W5100 chip feels really warm.

I've bought my Arduino Uno here http://www.dealextreme.com/p/arduino-uno-2011-version-atmega328p-pu-usb-board-66909. Its seems a chinese version of the Uno R1. And I've bought a W5100 ethernet shield from here http://www.samenkopen.net/action_product/936552/134081 that may also be a chinese redesign of the Ethernet Shield. I don't know what version but it has microSD card connector and it says MEGA compatible.

I got my board to work. There were two problems. 1. Bad connection between ICSP connectors in middle of the board. You need to to plug the ethernet board in tightly. The ICSP pins are not long enough. 2. It helped to make these settings: byte mac[] = { 0x90, 0xA2, 0xDA, 0x00, 0x59, 0x67 }; byte ip[] = { 192,168,1,101 }; byte gateway[] = { 192, 168, 1, 254 }; byte subnet[] = { 255, 255, 255, 0 }; I'm not sure which line exactly made it work. It may be the gateway and subnet.

I have encountered this problem?You have a look this post. SD and W5100 CHIP_SELECT.

http://arduino.cc/forum/index.php/topic,79492.0.html