My nano BLE sense not working after some test ML

hello I bought two arduino nano 33 BLE I have the races after tests the led does not flash I changed the port and the USB cable but nothing works. that is the solution thank you very much, I do machine learning tests with simply yes and no.

Please confirm that when you plug in the Nano to USB that a COM port is allocated, that you have that port selected in the IDE and that you have the correct board selected in the IDE

If so, then load the Blink example sketch and upload it. What happens when you do that ?

yes thank you it worked in a while but after tests the LED does not work and we can not select the port on IDE.

What sort of tests did you do ?

I test the micro_speech to test yes and no recognition but the nano not detected yet. the LED green not blinks.


any one not have the solution please i work with OS LINUX 20.4 and IDE 1.8.15

  1. Did you connect anything to the board
  2. Did you feel like giving the board static electricity when you touched it
  3. Were you working on a metallic (conductive) surface
  4. Did you try a different USB (laptop, PC, wall outlet [though the outlet is the last choice])
  5. Is the board getting hot at a certain area when it is connected
  6. Could you have selected the wrong board when uploading and possibly have bricked it?

-I only connected my ASUS PC with LINUX as a system
-No I gave the static electricity only my USB cable
-Yes I tried another PC another USB cable
-I started to test an ML model as an example with a white board to plug in outputs as results LED but when I touched the nanon for a moment the green LED and holds after a while the LED comes back to life another times but when I unplug it after it no longer works
-the card does not heat up anymore
-I tested with two cards but the same problem for both.
-I think it's a circuit problem

hello does the green LED always light up if not the Nano are damaged? please because my LED green not working

You gave the static electricity to your cable. That energy was then stored into your cable, as it had no where to go. My best guess is that when you connected your board to your cable, the static damaged the board. Don’t use metallic cables, and before touching your electronics, touch a metallic surface that is away from you board and somewhere that you might not touch

thank you for your answer, how i can to fix it

You really can’t fix static electricity damage. It is easier and cheaper to buy a new board. If this is your first time working with Arduinos, get a cheaper UNO or NANO instead (Chinese clones are like $5 each). A 33 iOT is way to advanced for beginners

Thank you very much I'm working on an ML project to test yes or no that's why I bought an arduino nano 33 BLE sense.

No problem.

Would you explain a bit more on what ML project means? There might be easier and cheaper boards to work with instead,

I train a Machine learning model on google collab after it gives a good result I import it and I integrate it into arduino nano 33 ble which contains temperature and gesture sensors and a microphone that I use myself to test a sound if it is yes or no it lights an LED according to the choice in the program, I tested at the beginning it works well but after disconnecting my arduino and connecting it another time does not work because it is badly damaged if you are responsible in arduino.cc it is necessary to add indications of use of these components.

Yeah, a Nano 33 might work. An alternate solution could be to get a Mega clone for cheap and a voice recognition module (just YouTube Arduino voice recognition and you will get tons of tutorials).