My sketch won't upload to the arduino uno

I just finished testing some code on tinkercad and everything worked, but when I tried to upload it to the arduino uno, it sent an error message saying "Failed to retrieve licence (HTTP 403)" I have no clue what is wrong or how to fix the issue.

I guess you're using Arduino Web Editor. Is that correct?

If so, are you using it directly in your browser, or are you using the Arduino Create Chrome App on a ChromeOS device?

I am using the web editor and have it open on my browser.

As a test, try opening the site in an incognito window. This is an easy way to check whether the problem you're having is caused by cached files or a browser extension

If using the Google Chrome browser:

  • Click the button with the three vertical dots at the top right corner of Chrome.
  • Click "New incognito window".
  • Open https://create.arduino.cc/

If using the Firefox browser:

Now log in and try the upload again.

I am using my arduino for school and I can't open an incognito tab.

I am having the same issue regarding error “Failed to retrieve license (HTTP 403)”. I tried doing the incognito tab thing, but it still didn’t work. Please help.

Just to add to this. Arduino Create won’t upload the sketch on a Chromebook. I was able to upload the same sketch (Blink) onto a Nano (328P Old Bootloader) (tried Lafvin Uno and Arduino Uno too) with my Mac on the same account. However, when I try to do the same on the Chromebook, I get the HTTP 403 error. The school I am trying to help has a bunch of Chromebooks and I am trying to get an Arduino IDE working.

One more update to the question (still won’t work on Arduino Editor). Tried uploading a sketch with Codebender on the same machine and it worked fine.

Update: The next time I logged in, it asked me to reinstall the App; then it worked.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.