My YUN's linux side may be broken

Hello guys!

I received my YUN yesterday and then started hacking it with code. When opkg warned me about space is being full. I manually reboot my YUN with 'reboot' command. It killed my SSH connection which YUN is rebooting the linux, which that is normal.

When YUN's WLAN led is on, I tried to visit http://arduino.local. The page loaded then redirect to http://arduino.local/cgi-bin/luci/webpanel/homepage, but my browser can't find it (Oops Google Chrome couldn't find ardiuno.local).

Then I tried to connect to YUN via SSH, but getting operation timeout few times.

My Wifi router showed that my YUN's wifi connection is not connected to my Wifi router.

Attempted to use Yun Terminal via arduino side, but my Mac can't find serial port for it.

I have tried to restore YUN's linux factory default state by holding WLAN reset button for 30-60 seconds. The WLAN led was pulsing until I released the button. It didn't fix the problem. Tried to YUN reset and other buttons. Nothing worked.

I have spent half day of scouring for solutions from this forum and all blogs I found from Google Results. I am running out of ideas how to fix my YUN.

Is my YUN bricked?

I think you have two issues, you may have filled your flash that is being used as disk space on the Linino half, that is easy to fix once you get to a console through the Leonardo half.

I don't understand why you don't get a serial connection to the Leonardo side it is separate from the Linino side. Does a yellow led flash when you press the 32U4 reset button? This should reset the Leonardo and start the last sketch you loaded. Shortly (a few seconds) thereafter you should see a serial connection on the host computer.

Once you get there you should be able to load the YunSerialMonitor sketch over the USB and get into failsafe mode and run reset_to_factory_anyway then have Linino as it was when you received the board. This thread should help once you get the YunSerialTerminal running-http://forum.arduino.cc/index.php?topic=195589.msg1443502#msg1443502

Thanks! It is completely restored. :slight_smile:

@noblepepper, I've sketched a tutorial on the playground Arduino Playground - HomePage
Can you check it?

Looks good.

/usr/bin is in the path in failsafe so one step is unnecessary but it definitely should work as written, I didn't go as far as resetting mine :wink: