Mystery Atmega328?

During a routine build using Atmega328p-au,the company sent me Atmega328U-TH chips instead.
After failed attempts to program like I always do with simplicity,decided to then check the markings and found it was not what I normally use.This chip will not program like the P-AU.
Anyone even see these before and if so,details ?
Jim

It looks like you have an ATMEGA328 ( without the 'P' for pico power).
I did this with the DIP version and have since managed to use 2 (of the 5) so far that I bought in error.

I seem to remember playing around with a table belonging to AVRDUDE to edit device signatures in order to get a boot loader installed.

Google for "arduino atmega328 (not pico power)"

Alternatively, refer to the your supplier.

Since Microchip bought Atmel, they changed the markings on the Atmel chips. I think what you have is the same as the old ATmega328-au.

The easiest way to use the ATmega328 is by installing MiniCore:

Then you can select Tools > Board > ATmega328 and then Tools > Variant > 328 / 328A.

I do not use the chip for Arduino sketches and do not install bootloader.I directly load fuse settings then HEX and last my EEP. Using the 328p-au never fails me but this one is a head scratcher.
No big deal as I bought 3 and the company refunded my money without question and are sending the proper chips.
Which by the way…ARROW for USA purchases can not be beat.I ordered these Thursday and got them Friday.
Free over night shipping…not bad at all.
https://www.arrow.com/en/products/atmega328p-au/microchip-technology
The new were ordered this morning,should be here tomorrow so these can go in the junk box until I get bored :slight_smile:
Thanks for tips and will see about using these.

For a '328 instead of '328p, just adjust the avrdude command to specify the m328 instead of m328p (or maybe it's mega328 instead of mega328p).

Now that is a great point and will try that this morning.
Should have thought of that myself…thanks again for tips.
It will be nice to use them rather they sit in a box.A fun project anyhow and wanted to share these chips.
Jim

Tried the command without the "P"...no luck.
M328
Only one listed under the choices in AVRDUDE is m328p besides.Not sure if that is why.
Will just wait for the p-au to arrive and move on.

Hmm, my Avrdude 6.3 has it listed:

  m328     = ATmega328
  m328p    = ATmega328P

It's matter avrdude.conf.

Let me see if I can install the same...thought I was up to date.
Thanks once again for info.

Avrdude is a part of Arduino SW, actually in v6.3. Please verify.
It is also available on internet, it's open source.

Updated my AVRDUDE and it now shows 6.3 when started.It also shows both m328p and m328 in the menu.
Tried another AVR programming using both m328p / m328 commands and still nothing.
Going to wait for the new 328p-au chips and try one of those to verify it is not something else going wrong.
Not long ago had plugged a project into the programmer using the very same methods and it worked perfectly...so doubt this is any other problem other than this new chip...but never know.
Will post results soon as I can.
And here is my typical routine for programming this project repeated dozens of times with success -

Jim

What do you mean by "nothing"? If the process failed, then avrdude should have displayed an error message.

Yes,error in AVRDUDE -
My attempts to program the Atmega 328U-TH microcontroller Integrated circuit will not upload my commands in AVRDUDE using my USB AVR pocket programmer.
New and proper replacements arrive today...it works perfectly now...the end :slight_smile:

N2NXZ:
Yes,error in AVRDUDE

Don't you think it would be useful to post the error message?

Pert...it is typical error when an Atmega your trying to program fails to comm with progammer...you can stick a marshmallow on the PCB and get the same error...no big deal.Just your basic chip will not program error in AVRDUDE. Just like a bad solder joint on one of the legs...etc.
I bought 3 chips and the seller sent the wrong types,now have the proper type and it works as always.
I build the same circuit many times and the non working chips to me are junk and cost me 3 bucks...not worth another second of my time. Life is too short :slight_smile:
Jim

Ok...this was posted earlier above and is how my typical commands go for this particular circuit using Atmega328p-au.I got some Atmega328u-th and they do not work the way seen in this video.
I upgraded to AVRDUDE 6.3 with the plain m328...neither the m328p or just m328 command works.Using m328 I get menu for chip commands when trying to set fuses or anything else I try.Using m328p tells me programmer not found.
New chips and the RIGHT chips came in today...programming went as smooth as silk.
So the unknown chips are useless to me.Did my best but now not worth the time but gave an effort to say I tried.I learned not to spend too much time for 5 dollar parts...besides,I was refunded and they are now just free junk box chips...win win except the task of solder/de-soldering those SOB`s without wrecking the PCB.
So one thing gained...more practice and now can do it with a blind fold ...lol.
Jim

You keep saying you’re over it, but then you keep coming back and posting more, yet still not providing the basic information we need to help you. It should be common sense that when you’re posting on the forum about an error, you provide the complete error message.

Pert,not sure what your goal is here.
I am no newbie and asked about a chip to a forum where anyone could either answer the question,or not.
No one knows anything about this chip...so details are a waste of time.
I am only coming back now to answer a new question...why do you keep pushing on this?
Have YOU used an Atmega328U-TH micro before successfully?
You seem to be the only person that is bothered by the fact I have not taken time to send screenshots and full details about this chip not taking my commands.
I never really cared about the chip from the beginning and can care less.This post was pure curiosity and if someone had used one of these successfully,then it would have saved me the de-soldering time and would have used it and been done.
Now just trying to see what it is bothering you.
In a way,I get a feeling your trying to talk me down?
Or are you very interested in this chip and truly want to know more about it?
If you answer is the second,then I will take the time to make a full video and screenshots step by step for you.My first post shows the chip and even with my poor eyesight,can clearly see the markings.Assuming you can too.Also mentioned it was the WRONG chip that was sent to me and was no big deal and was awaiting the proper chips to arrive.Meanwhile,I wanted to see about this particular chip out of pure fun AND maybe help others that have the same issue if I found a solution.
Clearly,no one knows anything about this chip and the new proper chips have arrived and the job is done...business as usual here. This is a hobby,not a business and for me to sit in a chair for days on a chip that has no use to me is pointless.Some people can do that...not for me.Maybe someday this chip will circulate to others and this topic will be refreshed...I`ll probably never know it.
I hope this makes sense to you?
My project has many gears...time to shift into second -
https://www.qrp-labs.com/flights/u3s22.html
Jim

Ok...took the time to create a video of how the programming of this Atmega328U-TH is behaving.
I did this so as NOT to be just another post on a forum where some other poor person has the same issue only to find there is no solution...yet.This is something just about every forum on earth rarely does...and that is to end with something useful :slight_smile:
And the fact that when the next person Google searches a Atmega328U-TH,they will most likely find this thread because nowhere is anything else about this thing.
Here is the Atmega328U-TH when I try to program it using routine procedures -

And here is an older video of how it is supposed to work and has many times using ANY of the Atmega328P-PU or 328P-AU.

And by the way...see the comment on the second video...he says the video is too fast to see what is going on.
This is a person that does not realize the "PAUSE" option on YouTube but yet wants to program an Atmega chip?
Gotta love the internet!
Jim

N2NXZ:
And the fact that when the next person Google searches a Atmega328U-TH,they will most likely find this thread

This is true, and for that reason I'll take the time to link to @N2NXZ's cross-post which contains the conclusion to the story:

I found the issue with this TH chip.

They DO WORK and the issue all along was a bad programming cable.It just so happened it worked on other chips by pure coincidence.

After trying p-AU and finding they also were not working.

New cable proves they work fine.