Nano 33 BLE Cannot upload anything; enters bootloader

Hi.
I just received a new Nano 33 BLE and when I tried to upload a sketch, a message appears from the bootloader and nothing happens.
The port is correct and it sees the Nano board.
When I first connected the board a warning appeared informing to install some software, which I have done.
I've been reading posts with similar issues and have tried several things, like pushing twice the reset button to upload the sketch again, changing the USB cable, uploading a basic example: Bareminimum, but nothing works.
I'm using IDE 1.8.13 and an iMac running 10.15.7
Just below you can see the message I receive.

Please any help is very welcome.
Thank you in advance.
Dany

El Sketch usa 86672 bytes (8%) del espacio de almacenamiento de programa. El máximo es 983040 bytes.
Las variables Globales usan 44696 bytes (17%) de la memoria dinámica, dejando 217448 bytes para las variables locales. El máximo es 262144 bytes.
Device : nRF52840-QIAA
Version : Arduino Bootloader (SAM-BA extended) 2.0 [Arduino:IKXYZ]
Address : 0x0
Pages : 256
Page Size : 4096 bytes
Total Size : 1024KB
Planes : 1
Lock Regions : 0
Locked : none
Security : false
Erase flash

Done in 0.001 seconds
Write 86680 bytes to flash (22 pages)
[==============================] 100% (22/22 pages)
Done in 3.486 seconds

This is the output for a successful upload. Congratulations!

Now get back to having fun with your nice new Nano 33 BLE.

If you're not getting the results you expect from the sketch, then we can probably help you with that, but only if you provide us with enough information.

Ok. Thanks a lot.
I have some experience with Arduino Uno boards and this looked different to me, I thought it was some kind of an error.
This also because other things didn't work either. I was trying to use an distance sensor (VL53L0x) and it didn´t turn on, so I thought the BLE wasn´t working. Using a tester I've just found out that the board isn't giving any volt through it's 5V output pin, where the DS is connected to. Although it's 3,3 V output pin is working correctly. Maybe the 5V pin isn't enabled on this board? I'll have to find out.
Thank you again.
Dany

Hi again, I've just found an answer to my last question. I found it on your web regarding the Nano 33 BLE board:

Please Read...
The microcontroller on the Arduino NANO 33 BLE runs at 3.3V, which means that you must never apply more than 3.3V to its Digital and Analog pins. Care must be taken when connecting sensors and actuators to assure that this limit of 3.3V is never exceeded. Connecting higher voltage signals, like the 5V commonly used with the other Arduino boards, will damage the Arduino NANO 33 BLE.
To avoid such risk with existing projects, where you should be able to pull out a Nano and replace it with the new NANO 33 BLE, we have the 5V pin on the header, positioned between RST and A7 that is not connected as default factory setting. This means that if you have a design that takes 5V from that pin, it won't work immediately, as a precaution we put in place to draw your attention to the 3.3V compliance on digital and analog inputs.
5V on that pin is available only when two conditions are met: you make a solder bridge on the two pads marked as VUSB and you power the NANO 33 BLE through the USB port. If you power the board from the VIN pin, you won't get any regulated 5V and therefore even if you do the solder bridge, nothing will come out of that 5V pin. The 3.3V, on the other hand, is always available and supports enough current to drive your sensors. Please make your designs so that sensors and actuators are driven with 3.3V and work with 3.3V digital IO levels. 5V is now an option for many modules and 3.3V is becoming the standard voltage for electronic ICs.