Nano 33 BLE Sense not being recognized suddenly

My Arduino Nano 33 BLE Sense is not being recognized by my computer suddenly. The board isn’t showing up in the IDE’s port section. The port is grayed out.

Here are some of the things I tried onboard:

  • Double pressing reset button on the board didn’t make a response. (No flashing LED)

  • I’ve connected a led to the 3V pin of the board, luckily it turned ON. The board’s 3v, 5v, Vin all has output.

  • Changed the USB cable. Also connected to different USB ports of the pc, that didn’t work either.

Exactly when my board stopped working?

While I was working on ML projects using Edge Impulse, I’ve flashed their firmware to get the data from the board and it working like a charm for an hour. After sometime in idle, it got disconnected. And from that moment my pc doesn’t recognize it.

Physical condition of the board?
It’s brand new and I’ve used it for learning purpose.

I’ve also connected my other boards to the pc: Arduino Uno, Nano, etc. It’s all working and recognized. Not sure what’s the problem with this board.

IDE version: 1.8.13
Mbed OS Standalone Package version: 2.5.2

Sounds like problems I have seen in Windows 10. Shut the computer down completely then restart it so it has to reload the operating system, not the image that is saved when it shuts down. This will take longer than the general restart. After that point load the IDE and connect to the board. I expect it will show up.

I've tried. That didn't work either :frowning:

Also, when I double press the reset button quickly, The Arduino doesn't switch to the bootloader mode. The led on the board isn't pulsing.

Can you try a different unit? It is possible your current one is bad.