Nano 33 BLE sense not detected (SOLVED)

Hi all,

I've just bought an Arduino Nano 33 ble sense. My OS is Win10, I've installed the IDe from the store and run a couple of examples and everything is fine. Then, I've tried to use it with a virtual machine running with virtual box with Ubuntu 20.04.

I've installed the IDE from the Ubuntu app store (or how is it called), then connected the board from the toolbar on the bottom - board recognized (I've added my user to the group). Ok, compiled a sketch and tried to flash the board. An error on the log, something like "no board connected" but the flashing was completed with succes as I saw the Led blinking as the sketch was supposed to. So, checked, the board was back to win10. So I've set virtualbox to automatically connect the board to the virtual machine. Bad choice. Now the board is never recognized by the virutal machine and nor by win10. When I connect the board, win10 doesn't recognize it even if the virtual machine is not running.

Device manager tells me: Unknown device connected (device descriptor request not ok - or something like. sry translated from Italin I'm not sure). Tried to reinstall the driver but not success.

Any advice?


so, after following instruction in this post

I put the board in bootloader mode. Now, win10 can detect it and also the sketch I've uploaded is running.

My bad I didn't read the post!

This can be closed.