Nano 33 Ble Sense Stepper

Using the components below i built the circuit provided by the DRV8825 supplier website.
Note: wrong board in picture but thats the gist of it.

When powering on, the stepper jitters (shaft goes clockwise / counter clock wise repeatedly). When it should only be energize and holding in place.

When running a simple script (attached) the stepper continues to jitter.

When enabling micro stepping 1/16 or 1/32 it does the sequence while missing a crapton of steps.

the Stepper winding are fine, the resistance per coil is nominal as per its spec sheet.

there is ~ 1.1 - 1.5amps per phase (depending on where i set the vref of the driver)

Any ideas why the stepper would jitter like that, even when no signal is sent?

the code attached is using the AccelStepper library, i have also tried the A4988 Library to the same result.

Details:
Stepper: 17hs15-1504s-x1
Driver: DRV8825
Supply to driver: 12v
vref on driver :0.63

DRV8825 pins

ENABLE: Disconnected
M0: Disconnected
M1: Disconnected
M2: high
RESET: high
SLEEP: high
STEP: D6
DIR: D5

sketch_mar05a.ino (978 Bytes)

Well. turns out there was a defect on my breadboard causing a bad ground for one of the GND pins...

cant find the delete button for this post so. if you have my issue check ur ground / breadboard D: