Nano 33 BLE stuck in upload mode

I just got the new nano 33 BLE board. After uploading the nano 33 BLE board through the board manager and the IMU library in the IDE, the first thing I did was upload the blink sketch to see the nano 33 BLE work and the sketch worked fine. Second thing I did was upload a sketch from GitHub to read outputs from the nano's accelerometer. When running this, the serial monitor showed "Failed to Initialize IMU". Then I slightly modified the sketch and uploaded again. Still didn't transmit accel data but it did transmit text strings.

But now this nano 33 BLE will not accept any new sketch - including blink. It goes into upload and gets stuck there. I tried it on another computer, another USB cable, etc. and nothing works. All my other Arduino boards work and program fine.

Any ideas on how to get this device to accept a new sketch?

I don't have any experience with the Nano 33 BLE boards, but I know on the SAMD boards if your sketch has blocked the upload process you can recover by putting the board into constant upload mode. It's worth a try anyway.

Try this:

  • Press the reset button on your board quickly twice. You should now see the LED on the board pulsing, which means the bootloader is running. The double press causes the bootloader to run indefinitely (until the board is reset, powered off, or an upload is done), which means you don't need to get the timing of the reset just right.
  • Select the port of your board from the Tools > Port menu. The port will be different when the bootloader is running so don't assume you already have the correct port selected.
  • Start an upload in the Arduino IDE.

The upload should now finish successfully. After this, you should be able to go back to doing normal uploads without needing to press the reset button. If you still need to do the reset trick to do uploads after this, the problem may be caused by your code. You can verify this by uploading a simple sketch like File > Examples > 01.Basics > BareMinimum.

That worked! Thanks!!! :slight_smile:

You're welcome. I'm glad to hear it's working now. Enjoy!
Per

Praise be!!!!

I've just had this exact same problem however I'm so new to this that I didn't realise it was in upload mode and panicked thinking I'd just broken my new toy! Happened across this post by searching "Nano 33" across the whole forum.

At least now i have some idea what the LED flashing means :slight_smile:

Thanks!

Sometimes if an upload fails it will put the board into bootloader mode, just as if you had done a double press of the reset button. You might need to select the bootloader's port from the Tools > Port menu, but after that you should be able to upload a sketch.