Nano 33 IoT NINA update fails

I have a Nano 33 IoT that I have been trying to use in conjunction with the Arduino IOT cloud. I purchased two boards in february tested them, connected fine, programmed and moved on. I had to design the supporting hardware in the meantime and have now finished but since picking it back up I cannot get the web editor to upload code to the nano.

  • I started with an old build of create agent so first updated that.
  • I then checked if I could upload code using the desktop IDE. This worked perfectly.
  • After searching I narrowed down the issue of the web editor to the changing COM ports when running versus bootloader mode broke the web editor for uploading code.
  • Manually assigning the COM port to the same value for each state finally allowed me to register the device with the IoT cloud.

This leads me to the next issue.

  • To upload a sketch the NINA firmware needs an update. The cloud editor fails with Executing command: exit status 1 every time.
    To fix this I have tried:
  • Reinstalling create agent up to 1.2.4-056c22e
  • Reinstalling drivers for the windows 10 device.
  • Swapping USB cables, Ports, and even tried using a hub with no discernible difference.
  • I tried updating through the IDE and even went as far as installing the newest build possible.
  • I have tried using another windows 10 device and a ubuntu device.
  • I have a second board out of the box which has the same result.

I think the issue is related to the Serial port on the device always being classed as "busy" as there seems to be no communication between the board and any IDE.
I thought maybe some code it was running may have been blocking the serial port but when I loaded the bareminimum sketch it still suggested the COM port was busy.
To verify it wasn't my desktop at fault I tested my Arduino Due and Adafruit Feather nRF52840 and nRF52832 all of which didn't display any issues.
I think the NINA update is being blocked by the Serial port being "closed" and I really don't understand how to fix this issue. I have run through every single help post related to updating NINA firmware and none of them work.
When using the IDE to update the firmware to latest the updater never is able to contact the board to update despite the code loading properly.
The Debug console always says Serial Ports: [ { "Name": "COM10", "SerialNumber": "", "IsOpen": false, "VendorID": "0x2341", "ProductID": "0x0057" } ]

Which version of the Arduino IDE are you using?

I have tried 1.8.13 and 1.8.15

OK. Unfortunately I don't have a good idea of what might be causing this problem, but I will suggest that you try the 2.0.0-beta.11 version of the beta-phase Arduino IDE 2.x. This version has a new firmware updater tool that uses the most modern software. You can download it here:
https://www.arduino.cc/en/software#experimental-software
This is primarily intended for beta testing, so you might prefer to go back to your stable Arduino IDE 1.8.15 for daily use. But if it gets your firmware updated that's a good thing.

If you like command line tools, you can use the Arduino Firmware Uploader instead:
https://arduino.github.io/arduino-fwuploader/latest/
This is the tool used under the hood by Arduino IDE 2.x, which just puts a nice GUI over it, so there is no difference between using the IDE or using the tool from the command line other than the GUI being convenient.

Hi, so I tried the 2.0.0-beta 11 version and still no dice. The firmware updater fails overtime without any verbose output. I tried using the SerialCallResponse.ino to check if serial was still broken and after uploading it was impossible to open the serial monitor again.

I have tried this and it didn't work

Do you see a port for the board listed in the Arduino IDE's Tools > Port menu?

image

image

image
First image is in bootloader mode
Second is after uploading
third is the error code from the serial monitor

Can you try the check firmware version from the WiFiNina library and let us know which version of the Firmware you currently have then please let us know the error message (screenshot) you get when you are using the Updater tool in offline IDE.


This shows what happens when I have uploaded the sketch and try to open the serial port and then switch to the current serial port and try to open it


includes flashing off Firmware updater sketch

Result of trying to run the updater