NANO 33 SENSE: COM not swapping back

HI all, I'm using Windows 10 and my Nano 33 BLE Sense comes up as COM6, but after programming the IDE is left looking for COM7, and opening the Serial Monitor produces the error "Board at COM7 is not available".

I've tried to find t a better Device Driver (than the default Windows one) at Nordic and installed their nRFgo Studio, but cannot find the actual driver.

Can anyone tell me if they have a driver have that works differently or an I trying to fix the wrong thing?

Possibly its the IDE that needs investigating.. From the Verbose upload output I see that:

Forcing reset using 1200bps open/close on port COM6
PORTS {COM4, COM6, } / {COM4, COM6, } => {}
PORTS {COM4, COM6, } / {COM4, COM6, COM7, } => {COM7, }
Found upload port: COM7
C:\Users\Dave\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.9.1-arduino1/bossac.exe -d --port=COM7 -U -i -e -w C:\Users\Dave\AppData\Local\Temp\arduino_build_416595/SimpleAccelerometer.ino.bin -R 
Set binary mode
version()=Arduino Bootloader (SAM-BA extended) 2.0 [Arduino:IKXYZ]
Connected at 921600 baud
identifyChip()=nRF52840-QIAA

etc...

The IDE has changed to COM7 to upload, but when upload is finished it does NOT change back to COM6

....
[==============================] 100% (21/21 pages)
Done in 3.292 seconds
reset()

and when I open the Serial Monitor

Board at COM7 is not available

So 'whatever' in the IDE has changed COM ports and not changed back after issuing the 'reset'.

@dbuggz

It is NOT your driver. Please leave that aspect alone.

Also the verbose does not say "etc..." The reason for two ports is explained in the sticky posts that you passed on your way in.

Could you take a few moments to Learn How To Use The Forum. Other general help and troubleshooting advice can be found here. It will help you get the best out of the forum in the future.

@ballscrewbob,

I'm aware that NANO 33 (like many devices) exposes two COM ports.

I want to know why the IDE can switch COM ports but is not able to go back to the original when it's finished flashing, and the user has to perform a 'workaround' of selecting Tools|Port.

The IDE knows and expects this type of action and can handle it.

Your words not mine. :confused:

Is it the IDE or the Windows Driver?

Also, next time when I want to save you reading extraneous output like 20 lines of progress bars, I'll say 'snip' instead.

Because it is not the normal behaviour I think posting your sketch may be a good move along with a schematic of whats connected but preferably the former.

I was being a little flip at “etc” as often people leave out things that are still important.
But I am old school so I understand quite well.

IIRC there has been mention of this before and it was win 10 related I think.
Maybe browse the other new NANO sections to check ?
I will ask somebody with more knowledge though to take a peek.

@ballscrewbob

I was just getting familiar with the BLE Sense and ran several of the example sketches (with no external devices connected). After getting the problem several times (for different examples) I tried connecting directly to the USB3 port instead of the small (powered) USB I was using (one of the FAQs suggests the opposite may have been a fix). Same result. .

The log was from SimpleAccelerometer.ino . The first snippet I posted shows bosac uploading the .bin.

Dave

The problem is that the bootloader and the built in serial monitor use different COM ports but for Windows it is the same program. Perhaps using an external monitor would make life easier. I did not try that.

In case anybody looks for an answer other than 42, here's what I do now for a workaround:

1 double press the reset button on the board, the yellow LED should start blinking slowly 2 In the IDE Tools / Port > select the port the board is on (In my case COM6) 3 Upload the sketch 4 In the IDE Tools / Port > select the port the board is on (In my case COM5) 5 Open the serial monitor to enjoy the output of your master piece. 6 Before you upload a new sketch: Close the serial monitor, otherwise Windows adds a new port and the list gets longer and longer.

Aparently there has been an update to the IDE, for some weeks now, although I can’t find a version number reflecting the changes. IIRC the version in the window header always showed “Arduino 1.8.13 (windows Store 1.8.39.0)”

The boardmanager now shows a new category: Arduino NRF528x Boards (Mbed OS)
The problem is not as annoying as it used to be. Still not 100% but a large improvement.

It is still adviced to close the serial monitor before you do a compile upload, but the IDE no longer produces a new Com port every time you (double) press the reset button on the board.
Neither does it bring trouble when you start compiling and uploading with the Serial monitor still open.

The success rate of compiling and uploading went from: failing most of the times to mostly success.

Still there is room for improvement.

When compiling and uploading without double pressing the reset button the serial connection must be set to the com port the serial monitor is on(in my case COM 5), even though the upload port is a different one. During compilation the IDE searches and switches automatically to the upload port (in my case COM 6).

When compiling and uploading with the double press, the serial connection must be set manually to the upload port.

After compile and upload the IDE will keep the board on the upload COM port which always leads to an error, but not a very serious one. All you have to do is switch the connection back to the com port the serial monitor is on.
You’ll have to do this manually this every time after compile uploading. It would be so-much better if the IDE automatically switches back to the Com-port it was on before the complilation.