Nano Clone - No Power to LED on Breadboard


I've got a Nano Clone that I've just soldered the legs onto, and am attempting a blink test. The blink test on the board itself is working fine, but when I attempt a blink test using the pins it does not appear to work. I've also tried using a voltmeter across the 5V and ground and it doesn't show much voltage at all. Any ideas? I'm quite new to all this so maybe I'm overlooking something or starting at the wrong place for troubleshooting. Any guidance would be greatly appreciated.


Please provide CLEAR photos of both sides of the board showing the power connections and how you have connected the external components.


Bad solder work, bad code, bad IDE settings, or bad board

While certainly bad solder work could be a contributing factor (I'm a newbie in this area), I picked up a second identical Nano today, and when I hooked it up to run the Blynk example from the Arduino IDE it worked.

Then I noticed that there are two grounds on this module, and earlier I had been using the gnd right next to the vin. I went back to my old module and switched over to the other gnd (next to the rst/d2) and it worked.

So I really don't know. This could be something specific to this clone. You would think ground would just work. It's possible that I soldered the same ground poorly on both modules, but not that probable. Who knows.


Both grounds are connected and clones just use already proven designs. Check your solder joints and also check your wire integrity.

Be aware that some breadboards have a split power rail. If you are using the power rail for your connections it could be something to watch out for. If the colored lines (red and blue?) on your breadboard are broken, the electric connections of the breadboard are also not connected internally.