Nano does not take 5V from the USB cable anymore.

I am having a most peculiar problem. I finished soldering a PCB with an arduino nano. It is nothing too fancy. Asside from some unused connectors to other things, there is a CD4051 mux and a 12V -5VDC-DC converter.

Ofcourse I carefully tested for short circuits, then I fed it with 12V DC and still no problems. Did found out that the supposedle 5V Dc converter was pooping out 3V3 instead....

Anyways. I disconnected the 12V supply, I walked to my computer, plugged in the USB cable and it also worked.... for about 1 second. Lights went out.. Feeding the arduino with the 12V still works though. So there is some live in the arduino, it just won't take 5V from the usb cable.

The cable itself is fine.
I don't get short circuit in the USB port.
I ofcourse did not feed it with the 12V and usb port at the same time, that is just FUBAR.
The arduino 5V pin is directly tied with the 5V line of the PCB. And there is just 1 multiplexer and the output side of the DC-DC converter.

I soldered the output of the DC-DC converter loose, but no change. I have also never had the experience that an output of such a device causes a short circuit unlike a normal voltage supply. I atleast cannot find a short circuit with the multimeter.

Unfortunately for me, the nano is soldered directly underneath the board (for the last time) and I cannot look underneath it.

I am going to try to program it by feeding it externally.

But would could I have possibly broken?

2 pics of the PCB


One difference is that the mux IO lines are also soldered now.

Bas

EDIT:
externaly feeding it, allows me to program!. So not all my prescious work is for nought